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Excel 2016: Formatting Beyond the Basics
1.5 hours

In this workshop we will learn to use conditional formatting to have Excel automatically format our data
sets based on the cell contents; how to use tables which provide filters and automatic alternating row
colors; apply themes to change the color schemes associated within our workbook; create comments to
make notes within the cells; and protect the worksheets and workbooks. This intermediate workshop
assumes prior experience with Microsoft Excel.
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Conditional Formatting

Using criteria, a set of rules, we can have Excel format the cells that match. The following exercises will
walk us through some of these powerful formatting aides. This tool works best if you select the cells you
want to format before you set any rules.

Finding Duplicates

1. Open Customers

2. Select Column A (Last)

3. Onthe Home Tab, in the Styles group, choose Conditional Formatting
4. Select Highlight Cell Rules, and then Duplicate Values...

Home e Page Layo o a

= X Cut - e == o, = B
. - =M ®- = - ?]
D s Copy - Calibri 11 A A = EF Wrap Text General r S Normal Bad 604
P omatpanier | B 1 U &A= = = S5 Elvegencemer - $ - % o 5 | oGl format 5| Neural
Clipboard m Font m Alignment [+ Number m F
— Highlight Cells Rules * Greater Than...
AL = £ | uas ]:
T

A B C D E F G Top/Bottom Rules * Less Than...

1 |LAST FIRST ADDRESS CITY ST ZIP BALANCE E Data B E 5
»
2 |Adams Annie 6831 NW 4th Ave Gainesville  FL 32655 & 23¢ LE | DR Between
3 |Appleton April PO Box 456 Starke FL 32689 S 467 [:] Color Scales R F Equal To
4 |Arlington  |Arnold 234 SE 45th Road Gainesville FL 32597 & 12¢f - ="
5 [Brown Bobbie 234 Peter Pan Terrace Gainesville FL 32597 S 13 Icon Sets ) Text that Contains...
6 |Bruce Butch 3243 SE 4th Terrace Gainesville FL 32608 S 10¢
7 |Cappers Cathy RR 2 Box 659 Waldo FL 34567 S 39; ] New Rule.. - A Date Occurring...
8 |[Carlson Carly 1943 NW Main Street Gainesville FL 32567 S 4333 ClearRules »
9 |clark Carl 9213 Kiwi Road Gainesville L 32667 $ 64[5 Manage Rules.. [ D Duplicate Values...
10 |Dawson Debbie 832 Hook Place Gainesville FL 32658 S 265.00 11/15/2017
11 |Edwards Edgar 5233 NW 232nd Drive  Gainesville  FL 32653 $  617.00  12/10/2016 More Rules..
F ~
5. Inthe Duplicate Values Window, leave the Duplicate Values m

light red fill setting and, click OK

Format cells that contain:
Scroll down to see the M's

Iz‘ values with | Light Red Fill with Dark Red Text Izl
7. Joe and John Jinks are different records, but

Marge and Marjorie look to be the same. oK l l Cancel ]

Insert Pﬂn:ll‘ lag.'nut Formulas Data Review View a
““EW L L . & | B wopTe Geres! - B, 4 v 8. Clear the formatting rules.
Faste R e e | BT U= == AT = EdMergeacenter - § - % 7 | 3 Condtional famatas N .
; : 0 : - Open the Conditional
A28 - £ | sinks Formatting menu again.
A B C D E F G H
25 |lennings Jasmine 465 SE 465th Place Gainesville FL 32653 S 522.00 5/5/2017 - Choose Clear RUIeS' and
26 loe 12 South University Ave  Gainesville  FL 32156 5 626.00 5/25/2017 choose Clear Rules
27 |links lohn 9324 7eus Street Gainesville FL I2684 S 419.00 5/15/2018 .
28 Johnson lack 2903 Endive Ave Gainesville FL 32608 S 17.00 4/25/2016 from Entire Sheet.
29 |loiner lake 9240 Grapefruit Place lacksonville FL 12768 S 794.00 B8/25/2018
30 Jones Jill 209 Cantaloupe Way Gainesville FL 32597 § 380.00 A4/5/2017
31 Katz Kerry PO Box 3346 Starke FL 32689 §  409.00 3/20/2016
32 |[Kent Kevin 2903 New Potato Drive Gainesville FL 12608 S 415.00 12/5/2016 Clear Rules from Selected Cells
33 King Kala RR 2 box 323 Waldo FL 34567 § 52.00 11/10/2018
34 Knight Katrina 9204 Avocado Ave Gainesville FL 32667 §  105.00 9/5/2018 [ Clear Rules from Entire Sheet ]
35 Kreck Kasper PO Box 3672 Gainesville FL 17680 § 467 .00 11/25/2016
36 |Lamas Larry 9405 Date Terrace Gainesville FL 17684 S 64.00 10/15/2017
37 |Lee Leslie 2930 Apricot Street lacksonville FL 32608 S 52.00 a/20/2017
38 (L Lana 23 lceberg Drive Gainesville FL 2597 § 157.00 215/2016
39 |Livingston Leanord 789 North University Ave  Waldo FL 12658 5 232.00 4af20/2017
40 |Lowe Lillian 942 Yam Way Gainesville FL 2684 5 132.00 10f/10/2017
41 Mack Mervin 2934 Turnip Place Gainesville FL 2608 5 236.00 sf25/2017
42 Martin Mary 230 Jalapeno Junction Jacksonville  FL 32297 5 67100 3/10/2016
43 McDade Madeline 8290 Apollo Ave Waldo FL 32658 §  219.00 6/10/2016
44 Mellott Marge 2309 Hercules Road Gainesville FL 32597 § 24200 9/20/2018
45 Mellott Marjorie 2309 Hercules Road Gainesville FL 32597 §  242.00 9/20/2018
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Top and Bottom Values @
We can sort the Balance column to find the top and bottom values listed, or we can BALANCE
have Excel format the cells to help them pop out. $ 236.00
1. Select Column G (balance) S 467.00
2. From Conditional Formatting choose Top/Bottom Rules S 12800
17.00
3. Choose Top 10 Items 2
$  106.00
- Notice you can change the number of items to be the top 3 or any number $  392.00
between 1 and 1000. S  432.00
. . . . . . S 64.00
4. Leave the default settings of 10 items, with a Light Red Fill. Click OK. ¢ 265,00
5. Go back to the Conditional Formatting, choose Top/Bottom Rules s 617:00
6. Choose Bottom 10 ltems $  364.00
7. Change the color setting to Green Fill and click OK. g 311.00
) ., . 157.00
Top 10 Items ? - Bottom 10 Items ? - $ 368.00
Format cells that rank in the TOP: Format cells that rank in the BOTTOM: S 415.00
10 =| with |Light Red Fill with Dark Red Text lz‘ 10 “ with Green Fill with Dark Green Text EI S e
S 501.00
[ oK l l Cancel ‘ [ oK l l Cancel ‘ S 319.00
S 486.00
8. Clear the formatting rules from the Conditional Formatting menu s 409.00
S 109.00
Data Bars
1. Select Column G (Balance)
2. From Conditional Formatting choose Data Bars
3. Hover over the different options to see a live preview of the embedded bar chart in
the cells. The larger the number, the longer the bar. G
BALANCE
- You can widen the column as much as you want, and the bars will stretch with ] 236
your column width. B ae7
[l 128
4. Choose one that you like | 17
- Set the number format to general to see them without the $ and decimals. D|:| ;gi
B 32
Color Scales [ 64

1. Select Column G (Balance)

2. From Conditional Formatting choose Color Scales

3. Hover over the different options to see a live preview of the shading. Notice the data bars are

still showing.
. . G
4. Clear all Conditional Formatting
BALANCE

5. Try the color scales again. 236
6. Sort the column to see the shading in action :g;
7. Undo the sort and Conditional Formatting 17
106
392
432
64

G
BALANCE
794
671
626
617
574
532
522
501




Icon Sets G G
1. Select Column G (Balance) BALANCE | | BALANCE
2. From Conditional Formatting choose Icon Sets < 432| |E 432
3. Hover over the different options to see a live preview of the icons : 22: % 22:
- As with the data bars and color scales these icons are relative to the A 617 |8 617
data in the entire column. Up arrows are above average, sideways =  364||@ 364
arrows are near average and down arrows are below average. = 31| |@ 311
4. Clear the formatting rules from the Conditional Formatting menu W 157/ |8 157
=> 363||@ 368
Custom Rule — Dates past due N . X
Tk‘lerej are date rules available in the Conditional Formatting, S ——
Highlight Cell Rules, you can c‘ho‘ose A Date Occurrlpg... Vesterday T with [t Red i wits Dok e Tert o
However, the rules here are limited. What | would like us to Vesterday
find is all the records (rows) where the date is past due. o ok | [ concar |
I the last 7 days
La?tweek
1. Select Column H (Due Date) Thie week
2. From Conditional Formatting choose New Rule... ast monh
3. From the top of the New Formatting Rule window, Next month
choose Format only cells that contain
- Change the second drop down list to less than m
. DUE DATE
- In the third box type: 2/10/2017
=Today() 9/25/2018
- Don't forget the equal sign and the parentheses 12/5/2017
3/25/2017
4. Click the Format button 5/5/2016
- Set the format to be Bold, with an Outline border, and a light grey fill 9/15/2016
lick OK he f d click OK he rul 5/25/2018
- Click OK to accept the format, and click OK to accept the rule. ‘ 6/1012016|
5. Leave this format

Select a Rule Type:

e Eoprnat all calle bocad op thoi walyes

= Format only cells that contain

= Format only top or bottom ranked values

= Format only values that are above or below average
= Format only unique or duplicate values

= Use a formula to determine which cells to format

Edit the Rule Description:

Format only cells with:

Cell value IE‘ less than E‘ R
prvin: posbcenyze | | romas. ||
[ QK l [ Cancel




Tables
We can format Excel ourselves using the tools found in the Font group. There are font styles, fill colors,
and borders. When we set up the format ourselves, we sometimes have to be careful about moving cells
around. It's very easy to lose a border format, or shade in the wrong color. If you need a formatted
structure with consistent colors, you may fall in love with Tables.
Create a Table structure

1. Return to Cell A1 (Ctrl Home)

2. From the Home tab, next to the Conditional Formatting button, choose Format as Table

3. Choose an option that has alternating colors for each row.

[IENOS nsert  Page layou!  Formulas  Data

e —
. )f e Calibri <l - A A = ®-  EPWrap Text General Bad Good €mm oX [y

O copy - . 8 . =

Pate e Paieer | B U= EE - - A 3 & F [FMergesCenter - § - % 2 Calculation . Insent Delete fom
Chpbeard . Fent . Aligrment 1 Mumber

Al - Ji LAST

A B I3 D E F

1 |I.AS] JFIRST ADDRESS CITy 51 LZIP

2 Adams Annie 6831 NW 4th Ave Gainesville FL 32655 236

3 appleton April PO Box 456 Starke FL 372689 467 af2EEEREE [EEEEE EEEEs 2ss toIt

4 Arlington  Arnold 234 SE 45th Road Gainesville Fl 32597 128 12/t EEEEE =EERE] EEERE EREEER FRRs

5 Rrown Robbie 234 Peter Pan Terrace Gainesville Fl 325497 17 3/ Medium

& Bruce Butch 3243 SF 4th Terrace Gainesville Fl 32608 106 5/t

7 Cappers Cathy RR 2 Box 659 Waldo Fl 34567 3492 9/1¢

& Carlson Carly 1943 NW Main Street Gainesville Fl 32567 432 S,-’?.f

9 Clark Carl 9213 Kiwi Road Gainesville Fl 32667 54[ /1 ===

10 Dawson Debbie 832 Hook Place Gainesville FL 32658 265 11/1!

Format As Table m

4. Excel should pick up the entire dataset. We have titles, ]
headers, so we'll leave that option checked. Click OK to fhere 15 the data foryour table?
ea ’ P : =$AS1:5HST¢]
see the result.

My table has headers
5. Our conditional formatting remains on the Due Dates.

o ] [ e ]

6. We now have a new tab in the ribbon to help us modify
the Design of the table.

FICHGEEEE
File Home Insert Page Layout Formulas Data Review  View ‘-';E‘ Tell me what you want to do...
Table Name: Summarize with PivotTable m Properties eader Row First Column | Filter Button
Tablel E-BRemove Duplicates Open in Browser Total Row Last Column
o - Insert | Export Refresh
) Resize Table 'S4 Convert to Range Slicer - - Unlink v| Banded Rows | | Banded Columns
Properties Tools External Table Data Table Style Options
Al - Je | LAsT
A B C D E F G H
1 - CITY - ST - ZIP - BALANC DUE DATE
Annie 6831 NW 4th Ave Gainesville FL 32655 236 2/10/2017

Appleton April PO Box 456 Starke FL 32689 467 9/25/2018
Arlington Arnold 234 SE 45th Road Gainesville FL 32597 128 12/5/2017
Brown Bobbie 234 Peter Pan Terrace Gainesville FL 32597 17 3/25/2017
Bruce Butch 3243 SE 4th Terrace Gainesville FL 32608 106 5/5/2016
Cappers Cathy RR 2 Box 659 Waldo FL 34567 392 9/15/2016
Carlson Carly 1943 NW Main Street Gainesville FL 32567 432 5/25/2018
Clark Carl 9213 Kiwi Road Gainesville FL 32667 64 6/10/2016

W o N oy s W N

7. Try the different table style options and table styles to see how it changes the format of our
table. One of the best features is the Total Row.

- With the total row turned on, scroll to the bottom of the dataset. The 77 represents how
many records we have. Click inside the Total for the Balance column and change it to Sum.




Removing the Table structure (Convert to range)
While the table structure is an awesome formatting tool, if you prefer to do your own customizations,
you will want to remove the automatic formatting.
1. From anywhere inside the table click the Convert to Range button on the Design tab.
- Converting this back to a range will break the data from the table structure, but will not
remove the formatting.

Undo!
On the Design tab, expand the Table Styles menu.

Choose the first option, "None"

vk N

Click on Convert to Range again

File Home Insert Page Layout Formulas Data Review View Design ¢/ Tell me what you want to do...

Table Name: [iZ] Summarize with PivotTable D | Header Row  [v/] First Column | Filter Button [ [== ===
oD =4 =4

Tablel | Total Row Last Column

Insert = Export Refresh

Slicer v| Banded Rows Banded Columns

Properties External Table Data Table Style Options Table Styles

6. From the Conditional Formatting menu on the Home tab, choose Clear Rules from Entire Sheet

Turn to the Summary worksheet

Adding/Deleting Rows in Tables
1. Onthe summary worksheet, set each grouping into a table that matches its heading.
- Click in cell A3 (Items)

Choose Format as Table from the Home tab (Ctrl-T)

Choose a table style that matches the year
Click OK to the range

Repeat for cell F3 (Items) and K3 (Items)

2. Clickin cell C7, Type: D
3. Press Enter to move to cell C8, Type: E and press enter

4. Right-click in Cell F6, Choose Insert a row below
5. Do it again
6. Typein D and E into the appropriate spots

7. Look for the small blue box (backwards L) in the bottom right corner of N6
Drag the box down two rows
9. Typein D and E into the appropriate spots

o

10. Right-click on the heading for Row 7, notice you cannot Insert or Delete
- These have to be done from inside each table.

11. Select Cells C7 & C8
12. Right-click - Delete the table rows
13. Repeat for each table

- F7&F8

- K7&K8

14. Or UNDO all the added rows




Doing Math in Tables
1. In Cell D4 press the equal sign (=)

2. Clickin cell B4 (123)

- Excel doesn't say B4, it says: =[@Price]
3. Type the multiply sign, the asterisk ( *)

4. Clickin Cell C4 (812)
- =[@Price]*[@Qty]

5. Press Enter to accept. All the equations are filled in
6. Turn on the totals row

7. Repeat for the other two tables

A B C ) E F G H 1 J K L M N
1| 2016 | | 2017 | | 2018
2
3 Items -|Price [-]Qty -| SubTotal - Items | - |Price |- |Qty - | SubTotal - Items | - | Price - | Qry - | SubTotal
4 A 123 812 99,876 A 123 552 67,896 A 123 79 9,717
5 B 456 G46 294 576 B 456 663 102,328 B 456 58 26,448
6 C 789 694 547,566 L /89 128 574,392 C /89 32 25,248
i Total 542,018 Total 944,616 , Total 61,413

8. Since these are such small tables, you may consider turning off the Filter Buttons as well.

Protecting Worksheets/Workbooks
If you would like to restrict people from making changes, including yourself, you may consider
protecting it. You'll find the option on the Review tab in the Changes group. From here you can decide

what users, including yourself, are allowed to do within this sheet. You do not have to set a password
unless you want one.

Once you have protected the sheet, the button will change to say Unprotect Sheet, use this option to
release the control.

If you would like to allow edits to specific cells, choose those cells and change their protection "lock cell"
option from the Format Cell menu, or Format Cell Window.

Review View Design Q Tell me what you want to do...
X Locking a worksheet hE|pS prevent Show/Hide Comment D g Protect and Share Workbook
EditS, and formatting, B I Show All Comments L7 Allow Users to Edit Ranges
. . . lext 5 Show Ink Protect Protect Share e r—
inserting/deleting columns and rows Sheet Workbook Workbook -7 |4ck CN1anges
hanges
and cells. ments . - .
Protect Sheet 7 -
’:’ LOCking a workbook heIpS prevent E F Protect worksheet and contents of locked cells )

changes to the workbook structure, Password to unprotect sheet:
like inserting/deleting worksheets. !

==

P Items [ |Pf| alow allusers o thisworisheetio |-
. 876 A Bl select locked cels |8
¢ If you forget the password, there is s76 | 0 %Selemmulzlcked cels E
. Farmat cells
no recovery. Either don't use a o = | Format columns 3 IZ_
1 S - 3 :‘ Format rows
password, or DON T FORGET IT' 018 Total :‘Insert columns 6
- | [ insert rows | P
[ nsert hyperlinks
Delete columns
[ | Delete rows %
[ oK ] [ Cancel




Protect Sheet
1. From the Review tab, choose Protect Sheet

2. Leave the defaults and click OK
3. Clickin cell C4 to and try to change the Qty

Microsoft Excel

-

! The cell or chart you're trying to change is on a protected sheet. To make a change, unprotect the sheet. You might be requested to enter a password.

4. From the Review tab, choose Unprotect Sheet

5. Select all the Qty cells C4:C6; H4:H6, M4:M6

- Use your control key, or do each section one at a time

6. Open the format cells window

Qty ~| SubTotal - Items |~ |Price ~|Qty ~ | SubTots
- Right-click in the selection, 812 99,876 A 123 552
or press Ctrl 1 646 294,576 B 456 663
694 547,566 C 789 728
7. Turn to the Protection tab 942.018 Total
Format Cells 7 -
8. Uncheck the Locked option and
. ‘ Number | Alignment Font | Border | Fill Protection
click OK J—
D Locked:
. D Hidden
9' From the REVIeW ta b’ Choose Locking cells or hiding formulas has no effect until you protect the worksheet (Review tab, Changes group,
Protect Sheet Protect Sheet buttan).

10. Leave the defaults and click OK
11. Click in cell C4 to and try to change the Qty

- No Problem!

Comments
A comment is a way to leave a subtle note within the
worksheet. In this case let's put a note with the 2018 Price

]
5 Show All Comments

New Delete Previous Next pe

title reminding people if they need to change the price, they | comment /5 Show Ink
will have to unprotect the sheet. Comments can be printed Comments
by choosing the option in the Page Setup on the sheet tab.
1. Unprotect sheet
2. Clickin Cell L3 (Price) 2018
m]
3. From the Review tab choose New Comment ltems - |Price  |-]qCowart: _ | =
To change the price you
4. Type your comment into the comment box A 123 Swill need to unprotect - 9,717
B 456 the sheet from the 26,448
5. Click outside of the box and it will disappear C /89 |Review tab. _ 25,248
6. Total 61,413

Notice the small red triangle in the upper

right corner of the box. That's our visual cue there is a comment in that cell.

7. Hover over your mouse over cell L3 to see the comment appear. If you can't see all the text, you
can click on the Edit Comment button that has taken the place of the New Comment button.

- Click inside the cell, Click Edit Comment, Resize the box, click outside the comment




Themes File Home  Tnsert [EEELCIEVSTAN Formulas

A theme is a preset list of default formatting for the workbook. ] B colors - '*‘ bl
L P & . o N @ ID [%g M
This includes the Fonts, Colors, and Effects. We typically stay Themes = °™ Margins Or,emamn Sze Print Bred

with the Office theme and choose custom colors when we want — @feiects- | - . ¢ smmn -
ice
them, but this is a way to change everything at once. e
Aa ’I Aa JU b B A ‘I
1. From the Page Layout tab, choose Themes [E— memms || |smssms| | |s=sess
Office Facet Integral
2. Hover over each theme to see it change the fonts and N
Aa Aa Aa
colors of your tables — i— — —

- Notice there is a scroll bar! More than you can see. lonBoard.. ~ Organic  Rewospect  Slice
Either scroll down, or grab the corner (-:) to stretch Aq 1 Aa 1 Aa ﬁ As |
the window. munnan — f— —

Wisp Badge Banded Basis
3. Return to the Office Theme at the top of the list =
Aa H Aa 1 Aa 1 Aa J

4. Click on the Colors option CLEE) N CCEET — momen

- This setting will change the colors and not the fonts seln o Ceetel et Cmp;
and effects l] Aa 1 Aa } Aa

5. Return to the Office color choices Damask Depth Dividend  Droplet [«

- Remember your choices here will change the sheets |E zrowse for Themes..

in the workbook. BQ save Current Theme..

Turn to the Numbers worksheet

i F 4
Numbers Exercises 4 | Nommal
Customize Color Scales Conditional Format as| Neutral
Formatting =~ Table -
1. Select Dataset from the Name Box
Highlight Cells Rules »
ey . . =]
2. Choose a Color Scale from the Conditional Formatting menu
T Top/Bottom Rules  »
" . I
3. Choose Mange Rules from the Conditional Formatting menu -
- 3 Data B + Teo
show formatting rules for: _[crrent Seleetion E‘ [:] Color Scales ¥
[ New Rule... l [ [/ Edit Rule.. l I < Delete Rule ] 45
Rule (applied in orQEPEREWRTFTmaY Applies to Stop If True Icon Sets »
Graded Color Scale I I =§B$2:5AAS2T 64
D MNew Rule...
L_‘ Clear Rules 3 &
E Manage Rules...
[ Edit Formatting Rule @
Select a Rule Type:
= = Format all cells based on their values
. . = Format only cells that contain
4' CIICk on the Edlt RUIe bUtton = Format only top or bottom ranked values
» Format only values that are above or below average
= If needed Cha nge tO a 2 C0|Or Scale = Format only unique or duplicate values
. = Use a formula to determine which cells to format
5. Pick two colors ] —
Edit the Rule Description:
- I recommend Somethlng I|ght Format all cells based on their values:
Format Style: | 3-Color Scale |z|
6. Click OK to accept your changes Minimum Maximum
Type: | Lowest Value Highest Value E
7. Click OK to leave the Rules Manager Vabig [ cues ol El Gighestvalvel S
. . Color: El [ El
8. Clear all Conditional Formatting from sheet —
review: |




Find Min, Max, and Average with Conditional Formatting
1. Click in the Name Box to see a pre-named range of Dataset

2. Choose Dataset (B2:227)

3. Create the functions for the small grouping in column AE

- In cell AE1 type: =Min(Dataset)
- In cell AE2 type: =Max(Dataset)
- In cell AE3 type: =Average(Dataset)
4. Select Dataset from the Name Box
5. Set a Conditional Format to find the min values

- Turn to the Home Tab

Choose Conditional Formatting
Choose Highlight Cells Equal To
Click in Cell AE1

Leave the formatting Light Red Fill...

6. Seta Conditional Format to find the max values
- Equal to Cell AE2, Green Fill ...

7. Set a Conditional Format to find the Avg values
- Equal to Cell AE3, Yellow Fill

8. Clear all Conditional Formatting from sheet

Too Much Data to Chart
1. Return to the top of the sheet (Ctrl Home)

2. From the Insert tab choose Recommended Charts

3. Click on each Recommended

( Equal To X ]

Format cells that are EQUAL TO:

=$aE$1] with | Light Red Fill with Dark Red Text [ |

( Equal To LEJ i& ]

Format cells that are EQUAL TO:

=$AE$2 with  ‘Green Fill with Dark Green Text El

[ equaito =]

Format cells that are EQUAL TO:

=$AE$3 with ¥ellow Fill with Dark ellow Text [~ |

Insert Chart
Chart to see the messy outcome |

Recommended Charts | all Charts |

- Each item or date may need
to be charted separately or
by quarter

4. Change to the All Charts tab to
see other possible previews.

5. Cancel the Insert Chart window. iAo

6. Select Dataset from Name Box

7. Return to the Home tab and set
a Conditional Format with Data
Bars for an embedded bar chart

8. Set a Conditional Format with a
Ratings Icons to see an
embedded pie-like chart

9. Clear all Conditional Formatting

-

Stacked Area

Chart Title
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A stacked area chart is used to display the relationship of parts to whole over time
or categories. Use it to show the magnitude of change over time or draw attention
to the total value across a trend.
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Sparklines

Instead of embedding the charts inside each cell, we can make individual mini charts for each row using
the Sparkline option on the Insert tab.

1. Select the data for 1/15/2016 (B2:AA2)

2. From the Insert tab, choose Line from the Sparkline group

Insert Page Layout Formulas Data Review View Q Tell me what you want to do...

[ Shapes - - = - B2- - n [T ]
b O as ® i E 2 ). EE .
= = T SmartArt sore I ': -\'\;" |I|I' i‘i - I ..(J‘ Itvf II. il
ine

nded Table Pictures Online . ® My Add-ins - Bing People Recommended e . i PivotChart 3D olumn Win/
les Pictures @+ Screenshot M " Maps Graph Charts ', ke )= = Map ~ Loss
Tlustrations Add-ins Charts & Tours parklines
3. Click in Cell AB2 to indicate where you want the embedded \
. y Create Sparklines @i_ﬁj
line chart to appear.
Choose the data that you want
4. Click OK to accept and create the line chart. DataRange: | B2:AA2 EH
5. Drag the Fill handle from the bottom corner of your new Choose where you want the sparines to be placed
. Location Range: | $4B$2| Bl
chart down to the last data row to create an embedded line SesHamtenas
chart for each line of data.

- Notice the new Sparkline Tools Design tab with options
to modify your Sparklines

46 80 69 47 57 19 88 70 33 94 WA

. 17 93 79 11 29 68 53 72 17 33 MWwhm
6. Make column AB wider to see 31 65 27 61 54 28 24 70 90 70 "l

the chart stretch out 95 42 43 84 24 72 74 43 27 64 Uy

63 66 33 25 24 20 66 52 99 67Vl
7. Delete Column AB 72 82 64 16 94 8 64 79 99 27 W

39 30 23 17 17 92 57 26 78 41 WM

Quick Totals
1. Return to the top of the worksheet (Ctrl-Home)

2. Choose Format as Table from the Home Tab
- Any style you'd like, Click OK
3. Turn on your Totals Row (Very boring!)
4. Reset table -
- Turn off the Totals Row, Set the table style to None, convert to a Range

- Or you can just UNDO!

5. Select Dataset from your Name Box

6. Hover your mouse near the fill handle until the Quick Analysis box pops up ().

7. Turn to the Totals tab Formatting Charts  Totals Tables Sparklines

- Choose the first Sum to create totals
below your selected data E E E E E’l Dz
. . . Sum Average Count % Total ~ Running Sum

- Open the Quick Analysis box again

Total
and choose the last Sum to create
totals near the end of your data

Formulas automatically calculate totals for you.

25 1492 1662 1474 1520
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More about Custom Conditional Formatting
(Modified from the Office Help)

To more easily find specific cells within a range of cells, you can format those specific cells based on a comparison
operator.

Quick formatting
1. Select one or more cells in a range, table, or PivotTable report.

2. Onthe Home tab, in the Style group, click the arrow next to Conditional Formatting, and then click
Highlight Cells Rules.

| e
K 25
Conditional Format Cell

Formatting = as Table = Styles =
Shyles

3. Select the command that you want such as Between, Equal To Text that Contains, or A Date Occurring.

4. Enter the values that you want to use, and then select a format.

Advanced formatting
1. Select one or more cells in a range, table, or PivotTable report.

2. Onthe Home tab, in the Styles group, click the arrow next to Conditional Formatting, and then click
Manage Rules.

The Conditional Formatting Rules Manager dialog box is displayed.
3. Do one of the following:
O To add a conditional format, click New Rule.
0 To change a conditional format, do the following:
i Select the rule, and then click Edit rule.
4. Under Select a Rule Type, click Format only cells that contain.
5. Under Edit the Rule Description, in the Format only cells with list box, do one of the following:

0 Format by number, date, or time - Select Cell Value, select a comparison operator, and then
enter a number, date, or time. If you enter a formula, start it with an equal sign (=). Invalid
formulas result in no formatting being applied. It's a good idea to test the formula to make sure
that it doesn't return an error value.

0 Format by text - Select Specific Text, choose a comparison operator, and then enter text. Quotes
are included in the search string, and you may use wildcard characters. The maximum length of a
string is 255 characters.

0 Format by date - Select Dates Occurring, and then select a date comparison.

0 Format cells with blanks or no blanks - Select Blanks or No Blanks. A blank value is a cell that
contains no data and is different from a cell that contains one or more spaces (spaces are
considered as text).

0 Format cells with error or no error values - Select Errors or No Errors. Error values include:
HH#HHE, #VALUE!, #DIV/0!, #HNAME?, #N/A, #REF!, #fNUM!, and #NULL!.

6. To specify a format, click Format. - The Format Cells dialog box is displayed.

7. Select the number, font, border, or fill format that you want to apply when the cell value meets the
condition, and then click OK. The formats that you select are displayed in the Preview box.
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More about Excel Tables

(Modified from the Office Help) . %] Chocolade
To make managing and analyzing a group of related data | 5 [ C | D | E |
easier, you can turn a range of cells into a Microsoft . . .
ey ang ) = glot-3_ E3lotr2 [ Grand Total B3
Office Excel table (previously known as an Excel list). A Chocolade & 74450 & 162.56 & 207.16
table typically contains related data in a series of EERmEEEY £ SR | LAY | & EEEnE
Scottish Longbreads $§ 1,267.50 % 1,082.50 § 2,330.00
worksheet rows and columns that have been formatted Sir Rodney's Scones § 1,418.00 $§ 756.00 §  2,174.00
as a table. By using the table features, you can then B L
K Chocolate Biscuits 3 943.89 $ 349.60 § 1,293.49
manage the data in the table rows and columns
independently from the data in other rows and columns
on the worksheet. i Botr1  Klotr2  KYGrand Total
Chocolade ‘El Sort Smallest to Largest $ 507.16
Gummibar , $ 6,328.80
Scottish L Al Sort Largest to Smallest $ 2.330.00
Elements of an Excel table Sir Rodne{ | Sort by Color v fs 2,174.00
A table can include the following elements: e =
Chocolate $ 1,293.49
e Header row - By default, a table has a header row. |z 'S 22,309.37 |
Number Filters L4
Every table column has filtering enabled in the =
:¢: (Sedect All
header row so that you can filter or sort your z S;:-:g
v §349,
table data quickly. R
e Banded rows - By default, alternate shading or . # | =sum(Table1{[#This Row],[Qtr 1]:[Qtr 2]])|
banding has been applied to the rows in atableto | B c D E |
better distinguish the data. t  Blotr1  EJotr2 K Grand Total
de $ 744,60 $ 162.56 | $
e Calculated columns - By entering a formula in one  p#rehen BERoC 0l (SRS 299 )} SINGSes 80
. Longbreads $ 1,267.50 $ 1,062.50 | $ 2,330.00
cell in a table column, you can create a calculated  fhey'sscones § 141800 ¢ 7s6.00|¢  2,174.00
. . .. . I sucre $ 4,728.00 $ 4,547.92|% 9,275.92
column in which that formula is instantly applied | gccie ¢  oazs0 ¢ se0s0)e 129340
to all other cells in that table column. L [#1428159 ]38, $ 22,305.37
e Total row - You can add a total row to your table Blotr 1 EJotr2 B Grand Total B
. . Chocolade 5 74460 $ 16256 $ 907.16
that provides access to summary functions (such e e
as the AVERAGE, COU NT, or SU M)' A dropdown SISOﬁiSh Longbreads $ 1,267.50 $ 1,062.50 $ 2,330.00
. i Sir Rodney's Scones § 1,418.00 $§ 756.00 $ 2,174.00
list appears in each total row cell so that you can Tarte au sucre $ 4,728.00 § 4547.92 §  9,275.92
. Chocolate Biscuits $ 943.89 § 34960 $§ 1,293.49
quickly calculate the totals that you want. E5.127.78 [§ 22,309.37
e Sizing handle - A sizing handle in the lower-right
corner of the table allows you to drag the table to
the size that you want.

Managing data in an Excel table

Inserting and deleting table rows and columns - You can use one of several ways to add rows

and columns to a table. You can quickly add a blank row at the end of the table, include adjacent
worksheet rows or worksheet columns in the table, or insert table rows and table columns
anywhere that you want. You can delete rows and columns as needed. You can also quickly
remove rows that contain duplicate data from a table.

Using a calculated column - To use a single formula that adjusts for each row in a table, you can

create a calculated column. A calculated column automatically expands to include additional
rows so that the formula is immediately extended to those rows.

Displaying and calculating table data totals - You can quickly total the data in a table by

displaying a totals row at the end of the table and then using the functions that are provided in

drop-down lists for each totals row cell.
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More about Sparklines

- - . WA el [T
Sparklines are little charts embedded in your cells to show the trend of your data.
You'll find the tools on the Insert tab, in their own group next to Charts. Line  Column Win/Loss
Sparklines
Line Column
A B C D E F G H A B C D E F G H
1 Items JAN FEB MAR  APR MAY  JUN 1 Items JAN FEB MAR  APR MAY  JUN
2 Pants 113 226 190 144 203 238 /|| 2 Pants 113 226 190 144 203 238 _Hm-ul
3 Shoes 252 361 241 263 340 286 /\_/\ 3 Shoes 252 361 241 263 340 286 _0__Na
4 Socks 424 208 279 271 168 281 “So—_- || 4 Socks 424 208 279 271 168 281 H_mm_m
- ~+ Create Sparklines
Create Sparklines o X You can select the data range at any time, but if
ou do so before you choose the Sparkline
Choose the data that you want y i y_ . X _p
— option, your selection will autofill into the Data
Data Range: |B1:G2 . Range.
Choose where you want the sparklines to be placed You can create the Sparkline for one cell and
Location Range: || then fill down the pattern and Excel will create
the Sparkline for each row's data. If you want to
[ oK ] [ Fancal I do all the rows at once, be sure to place the
L same number of cells in the Location Range.

Modify Sparklines
Click inside an existing Sparkline to see the Design tab.

Home Insert Page Layout Formulas Data Review View Developer Design
R [re— | High Point First Point | " = «| I sparkline Color - 1 I Group
AL [l P . wh bn(wh ly b Wy owh W g : ==
| | Low Point Last Point P P S P | B Marker Color - IT1 Ungroup
Line |Column Win/Loss : 5 = Axis
Negative Points varkers z - &2 Clear -
Type Show Style Group

Use the Edit Data drop down to change the range of your Sparkline data and location. You can do the
full group or the individual series.

The Show options put markers or color variations within the charts to help points stand out.

The Style options are used to make the charts look better.
- Use the Sparkline Color option to change the color and weight

(thickness) of the lines. | i Group
- The Marker Color option allows you to customize each of the markers. | Iiw‘”g“’“p
- Clear -

Horizontal Axis Options

By default, each Sparkline has its own axis range. Among many other things,
the Axis option allows you to set Same for All Sparklines so the charts are
easier to compare across multiple ranges. Notice there is a minimum and
maximum.

As you change the format, all of the Sparklines change. If you want to
modify them independently you can Ungroup the Sparklines. This allows
you to format each one, but if you decide to Group later, all the Sparklines
will have the same format.

v | General Axis Type
Date Axis Type...

Show Axis

Plot Data Right-to-Left
Vertical Axis Minimum Value Options
v | Automatic for Each Sparkline

Same for All Sparklines

Custom Value...
Vertical Axis Maximum Value Options
v | Automatic for Each Sparkline

Same for All Sparklines

Custom Value...
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