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This workshop assumes prior experience with Excel, Basics I recommended. Topics
include data groupings; creating and modifying charts; chart types; source data; chart
options; chart locations; formatting; adding trend lines and error bars.
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Charts
A chart helps you display your data into a graphical representation. There are many types of charts, but in this
class we'll focus on simple column, line, and pie charts. There are examples of other charts near the end of this
handouts.
The first thing to know is the data has to be organized so Excel can understand what you are trying to chart.
Excel will chart your data selection or your connected data range. As long as there are no blank columns and no
blank rows within your dataset, you can skip selecting the cells.
Chart Title

Value Axis

Category Axis
Legend

Here is a dataset we will use in class:
Item
Pants
Shoes
Socks
Blouses
Hats

1st Qtr
456
498
128
579
126

2nd Qtr
489
435
168
498
129

This is a structured collection of related data set in a table
format. When plotted onto a clustered column chart, like the
one shown above, the titles in the first column of the dataset
appear along our category axis. The titles in the first row
appear within the legend. The values are represented by the
height of each column.
Line charts are usually set up to go across a period of time,
think Time Line. For this chart I've used the Switch Row
Column tool so we can see the trend of the sales through the
year. In this case our first column titles appear in the legend,
and the first row of titles appears in our category axis.
Pie charts are usually created to display the breakdown of
the total values within the whole. Pie charts can only be
based on one set of data. When you try to create one with
the above dataset, you will only see the first value set appear
within the chart. If you want to go to an extreme and have all
four quarters show, try using a Doughnut chart.
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3rd Qtr
423
472
157
531
123

4th Qtr
468
436
138
589
119

Creating a Chart
To create a chart make sure your cursor is in the dataset you would like to plot. If you want a subset of the
dataset, select that portion. You can use your Ctrl key to add to a current selection.
You will find the Charts group on the Insert tab. Click on any small chart button to see a list of possible charts.

If you are unsure of the best chart option for your data use the Recommend Charts button. It will open the
Insert Chart window shown here.
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Chart Tools
When you select a chart, three buttons appear along the right side of the selection.

The plus sign is the Add Chart Element button. This option is used to add and
remove different pieces of your chart. The list of options will vary depending on
the type of chart. For example, a pie chart will not have a set of category axis
titles. As you hover your mouse over each option, you will see a small arrow head
pointing to the right. This will open another menu with more detailed choices.
Each menu also has a "More Options…" button which will open a Format Pane on
to customize each chart element.

There is a Chart Style Gallery and a Colors menu on the
Design tab, but the Chart Styles button, the paint brush
next to the chart, offers the same options.
If you are patient while you hover over each option, Excel
will provide you with a Live Preview of the result.
The Color options are available at the top of the menu.

The third button is a funnel. This is a Chart Filters button.
The Values group allows you to add and remove data
points from the chart.
The Names page allows you to change the labels that
appear in the legend (series) and axis titles (category).
The Select Data… option at the bottom of the window
opens the same window as the Select Data button on the
Design tab. From there you can change or adjust the
range of cells used to create this chart.
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Chart Tool Tabs
When a chart is selected two chart tool tabs appear at the end of the ribbon, Design and Format.
Design Tab

1

2

3

4

5

6

7

8

1. Add Chart Element – A menu of chart elements that can be added or removed to the chart. Each option
will have a expand arrow at the end of the element name that will provide specifics and a More Options
button to open the Format Pane. This is the same as the Add Chart Element button that appears next to
the selected chart.
2. Quick Layout – A variety of layouts that offer suggested views and choices that adjust the chart
elements such as adding a title, varying the space between columns, and moving the legend.
3. Change Colors – Different color that can be applied to your chart. Changing the Theme on the Page
Layout tab will give you a different sets of colors.
4. Chart Style Gallery – Different chart styles that can be applied to your chart. Because Excel
automatically adjusts the Ribbon to fit on your screen, your copy of Excel may show less options than
the picture above. Use the scroll arrows and open menu buttons at the right side of the gallery for more.
5. Switch Row/Column – Changes the direction the chart looks at
the data. In our column chart, each column is plotted on the
chart, when we Switch each row is plotted. We are swapping
the category labels with the legend labels.

6. Select Data – Opens a Select Data Source window
where you can customize the source of the chart
data, even edit the labels. Use this window to
reorder your legend and change how Line charts deal
with blank cell values.
7. Change Chart Type – Opens Insert Chart window
where you can change to other chart types. If you
have multiple series you can change each to be
different chart type by choosing the Combo chart
type from the bottom of the left pane.
8. Move Chart – By default when you create a chart it is
placed on the same worksheet as your data set. You can
move the chart to its own worksheet or to any existing
worksheet with the workbook.
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Item
Pants
Shoes
Socks
Blouses
Hats

1st Qtr
456
498
128
579
126

2nd Qtr
489
435
168
498
129

3rd Qtr
423
472
157
531
123

4th Qtr
468
436
138
589
119

Format Tab

1. Current Selection
a. Chart Elements – This box shows the currently selected Chart Element, and the menu provides a
list of the major chart elements. Choose an item from this list to select that element.
b. Format Selection – Opens the Format Pane based on the current selection shown in the Chart
Elements box.
c. Reset to Match Style – Changes the current selection to match the original style of the chart.
2. Insert Shape
a. Shape Gallery – Use this gallery to find a shape such as a block arrow to add
to your chart.
b. Change Shape – Use this tool to change the current shape to a different one,
perhaps a rectangle into a rounded rectangle.
3. Shape Styles
a. Style Gallery – Different shape styles, options will vary based on
the current selection.
b. Shape Fill – Menu of the most common fill colors and options,
such as pictures and textures. For more options, open the
Format Pane.
c. Shape Outline – Menu of the most common outline colors and
options, such as dashes and arrows. For more options open the
Format Pane.
d. Shape Effects – Menu of the most common shape effects, such
as shadows. For more options open the Format Pane.
4. WordArt Styles
a. WordArt Gallery – Different WordArt styles
b. Text Fill – Menu of the most common fill colors and options,
such as pictures and textures.
c. Text Outline – Menu of the most common outline colors and
options, such as dashes and line weight.
d. Text Effects – Menu of the most common Text effects, such as
shadows. For more options open the Format Pane.
5. Arrange – Change the alignment and arrangement of multiple charts. Use the Shift key to select more
than one chart at a time.
6. Size – Change the height and width of the chart.
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Format Pane
There are multiple ways to open the Format Pane.





Click on the Format Selection button in the Format tab
Click on More option from any menu
Right-click on a chart element and choose Format…
Double-click on a chart element

The format pane can remain open for as long as you need it. The properties shown change depending on the
current selection. The current selection is shown on the Format tab and in the title of the Format Pane.
The pane can be pulled free from the side by dragging the title toward the middle of the window. To return the
pane to the side of the window drag it back into place or double-click the title of the Format Pane.
To close the pane, click on the X in the upper right hand corner. If you accidentally close the pane, use any
method above to reopen it.
Within the Format Pane, click on each icon to see the subset of properties. Click on the expand arrow in front of
the options to see the relevant properties.

Fill & Line

Effects

Size & Properties

Options

Text Fill & Outline

Text Effects

Text Box Options

The Fill & Line and Effects options are the same for all the of the chart elements. If an option cannot be applied
to that chart element, Excel will disable (grey out) that option.
Below are the fill options for a Chart Element. Each Fill choice provides a new set of options.
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How do I …?
Change Axis Numbers
Select the Axis by clicking on a number in the area. Open the Format pane, be sure the title says Format Axis.
Click on the Options button.
From here you can:


Change the Minimum and Maximum numbers shown. These can be greater than the minimum and less
than the maximum if you want.



Change the Major unit, this is how the displayed number is chosen. If the major unit is 100 the chart axis
will read 100, 200, 300. If it's 25 the chart will show 25, 50, 75.



Change the Display Units to Thousands, Millions, Billions. This will change the unit shown in the labels
and data tables as well.



Change the Format of the numbers; number of decimals, include a dollar sign, etc.

Change Distance Between Columns
Select any column. Open the Format pane, be sure the title says Format Data Series.
Click on the Options button.
From here you can:


Change the selected series to be on a secondary axis



Change the distance the series overlap



Change the width between the each category grouping

Explode a Pie Chart
In the chart: Hover over a pie wedge. Click and drag the piece away from the center. To move one piece at a
time, select the single pie wedge first, and then move it from the middle.
In the properties: Select a pie wedge. Open the Format pane, be sure the title says Format Data Series.
Click on the Options button.
From here you can:


Change the rotation without changing the order of the data



Change the explosion, how close the wedges are to each other

Add Trendlines and Error Bars
Select the chart. Click on the Add Chart Element button in the Design tab, or on the

button next to the chart.

You can add your own custom error bars, if needed, from the error bar options. You do have to format one
series of error bars at a time.
Make Charts the Same Size
Use the Height and Width properties found on the Format tab in the ribbon, or on the Format Pane for the Chart
Area's Size & Options. You can use the alignment options on the format tab to make the charts line up.
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Changing the Data Source
From the Worksheet
When you select a chart, you will see the Chart Tool
tabs in the ribbon, and the three options buttons along
the right side of the chart. If you can see the cells in
the worksheet used for the chart, you will also be able
to see the data is selected and each section is shaded.
If you hover your mouse over the bottom right-hand
corner of the data grouping you will get the two-way
sizing arrow. If you click and drag the selection, you
can manually change the chart data source.
If you know, you will have more categories and series
you can grow the data area beyond what's showing
and Excel will assign new colors and make room in the
chart for the new values.
From the Select Data Source Window
From the Chart Tools Design tab, choose Select Data.
The Chart data range option can be a bit finicky so I
recommend deleting the current range and selecting
the new set from the worksheet.
The chart is initially arranged to follow the order of the
data, but if you would like the legend in a different order,
you can rearrange the Legend Entries using the up and
down arrows.
Removing data
Both of the above options will help you add and remove data. You can manually adjust the range in the
worksheet or you can select a different range from the Select Data Source window. Both are great as long as you
are using a consecutive range of data.
The Select Data Source window also had a Remove button to delete a series from
the chart. Notice there is not one for the Category/Axis labels. To be able to remove
one you will need to first Switch Row/Column. Once you have removed the
categories, Switch Row/Column again.
From the chart itself, you can click on the series you want to remove and press
Delete on the keyboard. You can only delete the series, so the same actions apply in
order to remove a category you will need to switch the row/columns first.
However, we now have a Filters button along the side of the selected chart. From
here, we can uncheck any of the values we do not want on the chart; Series and
Categories. You must click the Apply button at the bottom of the menu for the filter
to take effect.
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Types of Charts
Column and Bar Charts

Page 9

Line and Area Charts
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Pie and Donut Charts
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Hierarchy Chart

Statistic Charts
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Scatter (X,Y) and Bubble Charts
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Radar and Surface Charts
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Class Exercise
Explore workbook
-

Open ChartData.xlsx

-

View each worksheet

-

Discuss 'consistent' range of data

ROW TITLE
ROW TITLE

COLUMN TITLE
DATA
DATA

COLUMN TITLE
DATA
DATA

Create Chart
-

Turn to Sheet 'Sales by Quarter'

-

Turn to the Insert Tab

-

Click on Recommended Charts
o

Click on each suggestion to see a preview of our dataset

o

Click on the ALL CHARTS page at the top of the window and explore the options

o

Choose first Column Chart

-

Chart Tool tabs – Design and Format

-

Click outside of chart to deselect
o

Tabs disappear

Design Tab
-

-

Add Chart Element
o

Add: Data Labels on the Outside End

o

Remove: Chart Title

o

Move: Legend to the top

Explore different Quick Layouts
o

Choose first layout (title above, legend on right)

-

Explore different Chart Colors

-

Explore different Chart Styles

-

-

-

o

Notice it changes the Chart Layout

o

Return to the Quick Layout menu and choose the first one again

Switch Row/Column
o

Notice it's switching the legend with the category axis

o

Leave the chart with quarter in the legend

Select Data
o

Rearrange legend 4th Qtr - 1st Qtr

o

Cancel the window

Change Chart Type to different options
o

-

Reset it back to the original, first column chart

Move chart to its own sheet
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Format Tab – Current Selection
-

Select Plot Area from Current Selection dropdown

-

Click Format Selection button
o

Fill




o

-

Border


Solid line



Increase width



Gradient

Select Legend
o

o

-

Solid Fill
Gradient Fill
 Preset Colors
Picture or Texture Fill
 Textures
 Insert a file

Legend Options


Move legend to different positions



Try it with overlapping the chart

Effects


Add a Shadow



Add a Glow

In the Format tab in the ribbon, click Reset to Match Style

Layout Tab – Insert
-

-

Insert Shapes
o

Insert Block Arrow

o

Uses yellow diamond to modify arrow

o

Use green circle to rotate

o

Delete

Insert Text Box
o

Type inside

o

Move around

o

Delete

Delete Chart
-

Right-click on Chart 1 Sheet name

-

Select Delete

-

Confirm deletion
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Create Chart
-

Turn to Sheet 'Sales by Year

-

Insert Tab, Chart Group, Column
o

Choose first Column Chart

-

Move to a new worksheet

-

Change Font

-

o

Right-click on Category Axis (pants, shoes…)

o

Choose Font, sent size to 14

o

Undo

o

Right-click in Chart Area (blank space)

o

Choose Font, sent size to 14

Change Title to read "Yearly Sales

Format Tab - Styles
-

Select Major Gridlines

-

Change Shape Styles
o

Use Preset options

o

Use Shape Outline

o

Use Shape Effects

-

Select a column

-

Change Shape Styles

-

-

o

Use Preset options

o

Use Shape Fill

o

Use Shape Outline

o

Use Shape Effects

Format
o

Fill, Outline, and Effects for each column, independently

o

Fill for Plot Area

o

Fill for Chart Area

Format Chart Title
o

Change font size to 40

o

See Shape Styles, don't change it

o

See WordArt Styles


Text Fill



Text Outline



Text Effects
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Default Chart
-

In Sheet 'Sales by year' Press F11

Manually Changing Data Ranges
-

Insert a column chart on Sheet 'Sales by Quarter'

-

Notice color Coding around original data

-

Use fill handle to change the selection
o

If the colors go away, click inside the chart again.

o

Adjust the chart to include only the data

Filter Data
-

Insert a column chart

-

Use the Filter to remove second and fourth quarter, and remove your shoes

-

Use the Filter to add them back in

Remove Data
-

Click on a column for 4th Quarter
o

-

Press Delete on the keyboard

Click on a column for 2th Quarter
o

Press Delete on the keyboard

-

Notice the color grouping around our dataset is gone

-

Switch row/columns to remove shoes

-

Switch row/columns back

-

Open the filters button. There is only the first and third quarter, and no shoes

-

Delete Chart

Chart Specific Data
-

Select Items through 3rd Quarter, A1:D6

-

Insert a column chart

-

Delete 2th Quarter

-

Delete Chart

-

Select Items through 1st Quarter, A1:B6

-

Use Ctrl key to select 3rd Quarter, D1:D6

-

Insert a Column chart

-

Delete Chart
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Pie Chart
-

Turn to Sheet 'Sales by Year

-

Insert Tab, Chart Group, Pie, First chart

-

Remove Title & Legend

-

Add labels for %, Delete labels

-

Explode Pie

-

Rotate Pie (in the options)

-

Pull individual pieces

-

Delete Chart

3-D Column Chart
-

In Sheet 'Sales by Quarter'

-

Insert Tab, Chart Group, Column, Last 3-D option

-

Delete Legend

-

Design tab - Switch Row/Columns

-

Design tab – Select Data
o

-

Rearrange Legend so smaller values are in the front

Delete Chart

Line Chart
-

In Sheet 'Sales by Quarter'

-

Insert Tab, Chart Group, Line, First option

-

Design tab - Switch Row/Columns

-

Remove Smaller Values

-

Move to new sheet

-

Format Axis Options
o

Minimum 400

o

Maximum 600

o

Major Unit 25

Layout Tab - Analysis
-

Trend Line

-

Error Bars

-

o

More Error Bar Options

o

Fixed Value 5

Delete Chart
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