Access Reports 1:
Building a Report

training@health.ufl.edu




Access Reports 1: Building a Report

1.0 hour

[ L] oL 2 (=T o LoT o KPP PPPPPTPPPPRt 3
INSTANT REPOIT oo s s e e e s e s e s e s e s e s e s e e s s e s e s e s e s e s e sesesasnsesssssssasesssnsasnsnsnsnsnss 3
[0 oYL VAV A2 1o IS 3
(0= o Yo A =1V o 1WA 0] 11T o o = RSt 4
(0= o Yo =YY o 1U 11 oYU = T SRR 4
(0= o Yo =YY o 101Uy 1 =Y SRSt 4
FIEld SiZES ML ...coviiiieieeiee ettt s st st r ettt be e neene s 5
0=T o o] A =Tot o] 1 T T T T T T T T TP T PP PP 6
Yo Lo IE= TN 20T o Yol oo Yo o =1 SR 7
Create @ Report inN DESIZN VIBW ..ccciiiiiiiiiiiiiiiciiieiceececeeeeeeeeeeeeeeeeesee e e e ee e e e e e e eeeseeeseeeseeesesesesesesesesenenenens 8
N R oI B ] o101 =l 2U=T o Lo L o SRS 8
WOrking With Table StrUCTUIES........ueii ittt e e e et e e e st e e e e eatseessasaeeesnsaeeeennes 9
SOrting Data 0N @ REPOIT..cciiiiiiiiiiiiiiiiiiiieiirerereee et ee e e eeeeereeeeeeereeerererereeerererererererererererererererens 10
QUUICK FITEET ettt sttt et et b e r e r e e nesne e nee 10
Yo T Al 01 1= TP USSP PP 10
QUICK SOIt iN LAYOUL VIBW ..eeiiiiieiieeiie ettt sttt sttt sttt st st esbeesbeesbaesanee s 10

[ o T YV 2 T o F TSR P PP PRRPRRPRON 10
Same Report, DIffErent Data......cccccueeeecciie et e e tre e e ee e e st e e e sntae e s eanaeeeenreaeans 12
MAKE ThE QUETY ..eeiieee ettt sttt sttt st e b e e sat e e bt e e saee e beeessaeebaeenaeesane 12
(00T 03V o g LI T=T o Yo o SRS 12

UF UNIVERSITY of
FLORIDA
Pandora Rose Cowart

Education/Training Specialist Il
Educational Technologies, UF Health IT Training

E-206, Professional Park (352) 273-5051
PO Box 100002 prcowart@ufl.edu
Gainesville, FL 32610-0002 http://training.health.ufl.edu

Class Evaluation: https://go.ufl.edu/trainingeval

Updated: 10/30/2023



https://go.ufl.edu/trainingeval
mailto:prcowart@ufl.edu
http://training.health.ufl.edu/

e

e

Patient Reports
Instant Report

There is only one Instant Report, we'll have to use the wizard to see more Report types.

1.
2.

3.

Select Patients table

From the Create Tab, in the Reports group, click the Report button.

+  Adjust widths so the fields fit within the margin guides. If anything goes awry, Undo.

Save as Patients

& Patients
g Patients Menday, May 29, 2017
- 9:09:04 PM

Pt Med Rec Last Name First Name Address City ST
015-695 Jacobsen Jeffery 1398 NE 8th Ave, #1245 Gainesville FL
068-821 Perez Penelope 2034 Banana Drive Gainesville FL
073-809 Glass Gloria 2343 Kale Lane Gainesville FL
082-340 Knight Katrina 9204 Avecado Ave Gainesville FL
082-366 Smith Sarah 456 East Main Street Gainesville fl

105-469 Kent Kevin 2903 NewPotato Drive Gainesville FL
107-284 Xue Xena 2890 Poseidon Place Gainesville FL
117-723 Toole Todd 9240 Carrot Way Gainesville FL
124-988 Clark Carl 9213 Kiwi Road Gainesville fl

127-496 King Kala RR 2 box 323 Waldo FL
137-997 Rogers Robert 534 Lovers Lane Gainesville Fl
146-935 Jones Jill 209 Cantaloupe Way Gainesville FL
154-788 Owns Orville 723 SW 35th Blvd Gainesville FL
155-130 Finch Frank 409 SW 92nd Avenue Micanopy FL
155-612 Mack Mervin 2934 Turnip Place Gainesville FL
159-884 Ellis Emily PO Box 5544 Gainesville FL
165-936 Gentle Gary 9420 Horseradish Ave Gainesville FL
174-457 Jimenez Jose 12 South Boxer Ave Gainesville FL
186-280 Zinn Zelda 745 Nectarine Ave Gainesville FL
207-451 Fuller Francis 123 South;Main Street Gainesville FL

Report Wizard

1.

2.

Select Patients table

From the Create tab choose Report
Wizard.

+ Choose all the fields (next)
- No Grouping (next)

+ No Sorting (next)

*  Layout: Columnar, Portrait, Adjusting

field widths

+  Title: Patients Columnar

Repeat steps 1 and 2 for Layout: Tabular

Repeat steps 1 and 2 for Layout: Justified.

- Justified looks bad because of the

field sizes.

Report Wizard

Tables/Queries

Table: Patients

Available Fields:

Which fields do you want on your report?

You can choose from more than one table or query.

2

Selected Fields:

Pt Med Rec
Pt Last Name
Pt First Name
Pt Address
Pt City
Pt State

Report Wizard

How would you like to lay out your report?

Layout Orientation

(@) iColumnar

(@) Bortrait

() Tabular (7) Landscape

() Justified -
'

Adjust the field width so all fields fit on a

page.

Cancel I [ < Back

[ mee> ][ emisn
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Report Layout Columnar

Patients Columnar

Pt Med Rec 015-695

Last Name Jacobsen

First Name leffery

Address 1398 NE 8th Ave, #1245
City Gainesville

ST FL

Zip 32567

Pt Med Rec 068-821

Last Name Perez

First Name Penelope

Address 2034 Banana Drive
City Gainesville

ST FL

Zip 32567

Report Layout Tabular

Patients Tabular

Pt Med Rec Last Name First Name Address City ST Zip

015-695 Jacobsen Jeffery 1398 NE 8th Ave, Gainesville FL 32567
068-821 Perez Penelope 2034 Banana Dri  Gainesville FL 32567
073-809 Glass Gloria 2343 Kale Lane  Gainesville FL 32597
082-340 Knight Katrina 9204 Avocado Av Gainesville FL 32667
082-366 Smith Sarah 456 East Main Str Gainesville fl 32608
105-469 Kent Kevin 2903 New Potato Gainesville FL 32608
107-284 Xue Xena 2890 Poseidon Pl Gainesville FL 32597
117-723 Toole Todd 9240 Carrot Way Gainesville FL 32667
124-988 Clark Carl 9213 KiwiRoad  Gainesville fl 32667
127-496 King Kala RR 2 box 323 Waldo FL 34567
137-997 Rogers Robert 534 Lovers Lane Gainesville Fl 32653
146-935 Jones il 209 Cantaloupe  Gainesville FL 32597
154-788 Owns Orville 723 SW 35th Blv  Gainesville FL 326055
155-130 Finch Frank 409 SW 92nd Av  Micanopy FL 32608

Report Layout Justified

Patients Justified

Pt Med Rec
015-695

Last Name
Jacobsen

First Name
leffery

Address
1398 NE 8th Ave, #1245

City
Gainesville

ST
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Field Sizes Matter

Remember when you go through the instant
Form/Report tools or wizards Access looks at the
Field Size property to determine how big the text
boxes need to be. We can continually readjust
the text boxes every time we use these tools, or
we can make sure our field sizes are more
appropriate.

1. Close all database objects (tables, Forms,
Reports...).

2. Open the Patients table in Design view.
3.  Change the field sizes:

Pt MedRec 10
* Pt lLast Name 50
* Pt First Name 50
- Pt Address 255

- PtCity 50
+ Pt State 2
- Ptzip 15

j Patients

x

Field Name

#* Pt Med Rec
Pt Last Name
Pt First Name
Pt Address
Pt City
Pt State
Dt 7in

General | Lookup

Data Type Description (Optional)

Short Text
Short Text
Short Text
Short Text
Short Text
Short Text
Chart Tavt

Field Properties

Field Size

Input Mask

Caption

Defauft Value
Validation Rule
Validation Text
Required

Allow Zero Length
Indexed

Unicode Compression
IME Mode

IME Sentence Mode
Text Align

10|

Yes

Yes

Yes (No Duplicates)
No

No Control

None

General

The error message that appears when you enter a
value prohibited by the validation rule. Press F1 for
help on validation text.

Num Lock 4

.

4, Close and Save the table, confirm it is OK if data is lost.

5. Repeat the Report Wizard using the Justified layout.

6. Save as Patients Justified 2.

Patients Justified 2

2343 Kale Lane

Pt Med Rec |Last Name First Name
015-695 Jacobsen Jeffery
Address

1398 NE 8th Ave, #1245

City ST [zip

Gainesville FL 32567

Pt Med Rec Last Name First Name
068-821 Perez Penelope
Address

2034 Banana Drive

City ST [zip

Gainesville FL 32567

Pt Med Rec Last Name First Name
073-809 Glass Gloria
Address
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Report Sections

1.  Select Patients table
2. From the Create tab choose Report Wizard.
+ Choose all the fields (next)
- No Grouping (next)
+ No Sorting (next)
*  Layout: Tabular, Landscape, Adjusting field widths
+  Title: Patients Report Wizard »
+  Confirm replacing the report
3. Set Zoom to four‘ pages | The report ‘Patients’ already exists. Do you want to replace it?
Yes Mo
4, Report Sections
+ Report Header, "Patients" - first page only
- Page Header/Footer, "Med Rec, Last Name, First Name..." on every page
- Detail, each line of data every record
Patients -

The Design view of the Report shows the
four sections within the Report.

- Right-click on the Report to go to the
Design view.

e
¥ Report Header

¥ page Header

¥ Detail

t Med RecHPt Last Name ||Pt Filrst Namg

¥ page Footer
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Add a Report Footer

1. In the Design of the Report, stretch the Report Footer section. If you cannot drag the resize area,

use the Section properties.
2. Right-click inside the Report Footer section and choose a fill color.
3. Preview the Report to see where the Report footer will appear.

- Last page, after the last Record Detail, before the Page Footer.
4. From the Controls on the Design tab, choose the Label. Click to turn the tool on and click where

you would like the box to appear.

Create  External Data  Database Tools [BESTel
R
Controls

5.  Type "Created by [your name]"
6. Use the Format text tools on the Home or Format tab to adjust fonts, sizes, and colors.
7. Preview the Report.
8. Close and Save the Report.
Patients
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Create a Report in Design view

1.
2.

From the Create Tab, in the Reports group, click the Report Design.
Open the property sheet.

Click in the Grid of the Detail Section to see the Section properties.
Change the Height property to 2"
Click outside the grid to see the Report properties.
Change the Record Source property to Patients
Open the field list with the Add Existing Fields button on the Design tab.
Double-click on Pt Med Rec in the Field List./"
Go to the Print Preview to see the result.
0.25" margin + 0.25" Page header

+ 2.00" for each record (Detail)

This would work for a columnar Report.

Set up a Tabular Report

1.

In the Design view, move the Pt Med Rec label and text box as high as
you can in the detail section

Or set property Top to 0"

Reduce the height of the Detail section as far as it will go

Or set property height to 0". It cannot be zero because there
are objects in the way, but it will make it as small as possible.

Go to the Print Preview to see the result.

Adjust the spacing in the detail section so the data is not so tight.

You can eyeball this, but | would select the field, press the down
arrow key on my keyboard four times, press the up arrow 2 times.
This stretches out the detail section and re-centers my field within
the given space.

Move the label to the Page Header.

The label is attached to the text box, to sever their connection use
Cut. Cut the label from the detail section, paste in the Page Header
section.

Use the align and size tools to make the Report organized.

Make a matching Last Name column.
Go to the Print Preview to see the result.

Close and Save as Patients Draft 1.

Pt Med Rec

Pt Med Rec

Pt Med Rec

015-695

068-821

073-809

Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec
Pt Med Rec

015-695
068-821
073-809
082-340
082-366
105-469
107-284
117-723
124-938
127-496
137-997
146-935
154-788
155-130
155-612
159-884
165-936
174-457
186-280
207-451
210-844
227-324
263-730
269-583
269-852

Pt Med Rec

015-695

068-821

073-809

082-340

082-366

105-469

107-284

117-723

124-988

127-496

137997

146-935

154-788

155-130
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Working with Table Structures
* 1. From the Create Tab, in the Reports group, click the Report Design.
2. Open the Property Sheet (button on the Design tab).

3.  Click outside the grid to see the Form properties

Change the Record Source property to Patients
4.  Open the field list with the Add Existing Fields (button on the Design tab).
5. Click on Pt Med Rec and Shift-Click on Pt Zip

6. Drag the Selection onto the Form

When you drag the fields onto the Form/Report, each textbox is a single unit, you can resize and move it
independent of the other objects. Sometimes that's good so you can customize your Form/Report,
sometimes it's bad because resizing one thing requires you to resize EVERYTHING.

Home Create External Data Database Tools Design Arrange Format Page Setup 'f;? Tell me what you want to do...

. E‘l‘] 2 5 [ select Layout [Ej % =2 =
- = v [ select Column § i
Gridlingp Stacked Tabular Remove QInsert Insert Insert Insert Merge  Split Split Move Move

- Layout JAbove Below Left Right [ Select Row Vertically Horizontally Up Down Margins ~ Padding -
Table Rows & Columns Merge / Split IMove Position

Access provides table structures within the Form. They are a little cranky,
but usually worth the effort.

7. With all the fields selected, click on the Stacked option on the
Arrange tab.

Click in the grid to drop the selection. Then click on one field
to see that you're in a "table". IPt Address i

The plus sign in the corner is a "Table Move Handle", it will : e i
select everything in the table. You can use it to move the STTTTT [EERESERSTEbE:
table structure.

Once you're in a table structure, most of the Arrange tab will ipifi :
be enabled.

8. Swap the first and last name.

9. Select the whole table and click the Tabular option on the
Arrange tab.

This is much easier than individually moving the labels
into the page header one at a time.

10.  Swap the first and last name again.

11.  Select the whole table and choose the Remove Layout
option.

This removes the table structure but keeps the object
placements.

12. Close and don't save
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Sorting Data on a Report

The Sort options are available in the Data view of Tables, Queries, and Forms, but not in a Report. The
Sort Order of a dataset can be arranged in the Design view of a Query. If you want to limit the dataon a
Report or have it display the data in a specific order, you may want to set up a Query. It is possible to
sort a Report, but it has to be set in the structure of the Report.

Quick Filter
1. Open the Report Patients in Report view.
Notice the Sorting tools are disabled, but the filters are working.
2. Right-click on Waldo in the City Column. Choose Equals Waldo.
3. Click the Toggle filter button on the Home tab.

Filters are temporary. If you close the Report and reopen it, all the data will return.

Sort Order

1. Go to the Design view of the Report.

2. From the Design tab or from the right-click menu , open Croup Sarh and Tol

the Sorting and Grouping Options || Sortby CITY = withZontop = » More >

Depending on where you find the tool it has slightly E|5°” by LAST

different names: Group & Sort; Sorting and Grouping; (= Add a group |2} Add a

Group, Sort, and Total.

3. - Sort by City "with Z on top".

4. - Sort by Last Name "With A on top".

5. - Close and Don't Save.

Quick Sort in Layout View

1. Open the Patients Report in Layout view.

2. If needed, open the Group & Sort pane.

3. Right-click on a city and choose Sort Z to A.

4. Right-click on a last name and choose Sort A to Z.

This replaces the City sort, only one sort level this way.

Label Wizard

Labels are usually used to create folder labels, mailing labels, and name tags. You can create these
through a Mail Merge in Microsoft Word, or here in Access by using the Label Wizard. In Word, you're
able to modify the final result; in Access, you cannot modify the data on a Report.

Make sure you select the correct database object in the Navigation Pane, this wizard does not give you a
chance to change the record source.
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The label product number should be listed
on the box of labels.

1. Select Table Patients

2. From the Create tab, in the
Reports group, choose Labels

- find 5160
+  Leave Fontset asis

+ Build Label using keyboard as
needed

* No Sorting
- Save As Labels Patients 5160

You may get an error message. This
sometimes happens because labels are
often close to the edge of the page.
Usually the Report will print without a
problem, but this error message may
come up as a warning each time you run
the Report.

Label Wizard

This wizard creates standard labels or custom labels.

What label size would you like?

Product number: Dimensions: Number across:
5005 21/3"x33/8" 2 -
5096 23/4"x2 3/4"

11/2" x4"

3
2
11/2" x4" 2

Unit of Measure Label Type
(@) English () Metric (@) Sheetfeed () Continuous
Filter by manufacturer: Avery El

Label Wizard

Available fields:

What would you like on your mailing label?
Construct your label on the right by choosing fields from the left. You may also type
text that you would like to see on every label right onto the prototype.

Prototype label:

{Pt First Name} {Pt Last Name}
{Pt Address}

{Pt City}, {Pt State} {Pt Zip}

| cancal H < Back l[ Next > H Einish

Microsoft Access

)

Some data may not be displayed.

Show Help >>

‘0/ There is not enough horizontal space on the page for the number of columns and column spacing you specified.

Click Page Setup on the File menu, click the Columns tab, and then reduce the number of columns or the size of the columns.

Cancel

Jeffery Jacobsen

1398 NE 8th Ave, #1245

Gainesville, FL 32567

Katrina Knight
9204 Avocado Ave
Gainesville, FL 32667

Xena Xue
2890 Poseidon Place
Gainesville, FL 32597

Kala King
RR 2 box 323
Waldo, FL 34567

Orville Owns
723 SW 35th Blvd
Gainesville, FL 32655

Penelope Perez
2034 Banana Drive
Gainesville, FL 32567

Sarah Smith
456 East Main Street
Gainesville, fl 32608

Todd Toole
9240 Carrot Way
Gainesville, FL 32667

Robert Rogers
534 Lovers Lane
Gainesville, F1 32653

Frank Finch
409 SW 92nd Avenue
Micanopy, FL 32608

Gloria Glass
2343 Kale Lane
Gainesville, FL 32597

Kevin Kent
2903 New Potato Drive
Gainesville, FL 32608

Carl Clark
9213 Kiwi Road
Gainesville, fl 32667

Jill Jones
209 Cantaloupe Way
Gainesville, FL 32597

Mervin Mack
2934 Turnip Place
Gainesville, FL 32608
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Same Report, Different Data

Happens all the time. You have a beautiful Report, but it has the wrong data. You can try to recreate the
Report, but that is more work than needed.

Make the Query 3 Patients Not Gainesville

Again, if you only want part of the data, you should create Patients
a Query that produces the set you want. *
# Pt Med Rec

Pt Last Name

Pt First Name

1. From the Create tab, choose Query Design. Pt Address
Pt City

2. Add the Patients Table to the query. Pt State
Pt Zip

3. Add all the fields at once with the * option.

Double-click on the * at the top of the Patients 4

Table. The asterisk (*) represents the entire

dataset. Field: Patients.* Pt ;it)f
Table: | Patients Patients
. Sort:
4.  Add Pt City. Show: 7
. . Criteria: MNot "Gainesville"
Double-click on Pt City. or:

Since the * already brought a City field,
uncheck the Show option.

Set the criteria to Not "Gainesville".

5. Save as Patients not Gainesville.

Should be 21 records.

Copy the Report

You can open the original report and use the Save As option, but copying and pasting the original report
often produces better results. You may need to change the Report Property Caption to match the new
report.

1. Right-click on the report Labels Patients 5160 and Copy.

2. Right-click anywhere in the Navigation Pane and choose Paste.
3. Paste as: Labels Patients 5160 - Not Gainesville.
Property Sheet ®
4.  Right-click on the new report and go to the Design Selection type: Report
view. Report IZI

|F0rmat| Data | Event | Clther| All |

5. Open the property sheet.

Record Source atients Mot Gain
6.  Change the Record source property for the Report to Caption
. . . Pop Up Mo
Patients not Gainesville.

N »

7. Preview the Report.
If needed, say OK to the margin error message.

8. Savel!
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