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What is a Database? 
The term Database usually describes a collection of related "data" (information). An electronic database 
should allow you to store, sort, and retrieve data. You can create simple databases by creating a Word 
table or an Excel spreadsheet.  
 
For example, here we have a database of our patients: 
 

MedRec# First Name Last Name Birth Date Doctor 
123-456 Jack Nimble 06/08/82 Edwards 
987-654 Jill Pail 08/27/75 Lewis 
753-951 Mary Bluebell 12/08/61 Edwards 

 
Here is a database of our doctors: 
 

DocID # First Name Last Name Phone # 
999-999 Ken Edwards 555-1234 
888-888 Laura Lang 555-4567 
777-777 Yolanda Lewis 555-7890 

 
Why use Microsoft Access? 
Microsoft Access is a "relational" database application. Relational means we can link together sets of 
data, we can relate the data. We can keep track of the patients and the doctors, as well as when the 
patients last saw their doctors, what happened at each visit and so on. Access allows us to relate our 
data, without the repetition that may occur anywhere else. 
 
In an Access database, we can create the datasets and link them. 

MedRec# 
First 

Name 
Last 

Name 
Birth 
Date Doctor  DocID # 

First 
Name 

Last 
Name Phone# 

123-456 Jack Nimble 06/08/72 Edwards  999-999 Ken Edwards 555-1234 
987-654 Jill Pail 08/27/75 Lewis  888-888 Laura Lang 555-4567 
753-951 Mary Bluebell 12/08/61 Edwards  777-777 Yolanda Lewis 555-7890 

 
In Microsoft Access, data is stored in Tables. As data in the Tables change, the other database objects 
will reflect the newest information (i.e. the Queries, Forms and Reports). 
 
Queries show the data in a Table format. A Query can pull from multiple Tables and allow you to limit 
the records (rows) display by using criteria and showing only the fields (columns) you want. We can find 
the phone number for Jill Pail's Doctor, and provide Dr. Edwards with a list of his patients.  
 
Forms can be created to provide a "user-friendly" side to your database. They are used to view and 
enter your data in an interactive formatted structure. Forms are also used to make menus and search 
windows. They can turn a simple data collection tool into a more interactive user-friendly application.  
 
While you can print a Table, Query, or Form, Reports are uniquely created to print out your data. This 
tool can  group and organize data. They can be used to create Form letters and mailing labels. Access 
works beautifully with Word for mail merges, but the Reports tool allows for multi-level summaries. For 
example, a list of all the patient's upcoming appointments. 
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Planning the Database Tables 

The most important part of creating a relational database is planning. This can be difficult when you are 
new to relational databases. Here are some questions that may help: 

1. Input - What data do I already have for the database? 
2. Output - What information do I want to get out of the database?  
3. Process - What do I need to do to get there?  

Sometimes it helps to plan the final Reports that you want from your database. For example, we want to 
have a chart of how many patients attended their appointments. Do we track the cancellations vs. the 
no shows? What about the late arrivals and the rescheduled? If we want to differentiate, we need to 
make sure we are going to collect that data. This is why it's so important to plan, to try to predict the 
"what ifs" that may occur once you have your data collected. 

The Tables are the core of your Access database; these structures store the data. Tables are essential to 
using any of the other Access Tools. When planning your database try to remember the basic design 
rules for your Tables. 
 

Design Rules 
These are discussed during the PowerPoint presentation. 

Organizing Data 
Once you have an idea of the data you would like to collect, you need to decide how many tables you 
might use to organize the data efficiently. In Excel, we might keep several numbered columns to keep 
track of things, i.e. Medication1, Medication 2…, but in Access, we should create a second table to track 
the numbered fields. 

No Derived Fields 
By using the relationships between our tables, we can derive missing data. If we are creating a new 
appointment for a patient, we only need to put in their Medical Record Number (or other unique 
identifier). The patient's name, phone number, and other information can be retrieved, derived, from 
the Patient Table.  

Data is broken down into Smallest Logical Parts 
Pulling fields together in Access is often simple; pulling them apart usually requires human intervention. 
Think of this as breaking up the data into its smallest sort-able part. Anything you want to sort or filter 
should be in its own column. 

Descriptive Field Names 
It is tempting to use abbreviations when we are creating our data tables, but if the title we use is too 
vague or too abbreviated, we may not be able to recall why we created that field. DOB – Date of Birth or 
Department of Babies? SSN – Social Security Number or Shands System Number? 

Unique Field Names 
Be sure to differentiate between the field names in each Table. We can have a 'First Name' in our 
Patient Table and a 'First Name' in our Doctor Table but this can lead to confusion when we try to pull 
both Tables into one a report. Think 'Pt First Name' and 'Dr First Name'.  
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No Calculated Fields 
In Microsoft Excel, we can perform our calculations on the same sheet as our data, but a Table in Access 
is stagnant data, it does not change unless you make it change. Access will let you create calculations in 
Queries, Forms, and Reports. Newer versions of Access do have a Calculated field type for the table. This 
will embed a calculation in the record and is not always automatically populated in a data entry form.  

Unique Records  
It is important that each Table has a way to keep records (rows) unique. We can do this by setting one 
field (column) to be a Primary Key field. When a field is set as a Primary Key, Access will not allow any 
duplication nor blanks. When there is not a unique field in your collected data set, you can use an 
AutoNumber. AutoNumbers are incremented or random fields that are always unique. 
 
Microsoft Access Tables 

Tables store data. The Tables are the true 'database' (base of data). These need to be created and 
properly linked (related) in order to effectively use the other Access tools. Tables are the core of your 
database; everything else in Access depends on the Tables.  

Vocabulary 
A collection of fields make up a record. A collection of records make up a Table. A collection of Tables 
make up a database 

Datapoint – One Cell with in the data grid A Phone Number 

Field – One column of a Table common to all the 
records 

Everyone's phone number 

Record – One row of a Table containing all data about 
a particular entry 

One person's data, name, phone number… 

Table – One set of related data Everyone's data, names, phone numbers 

Database – Structured collection of related Tables  

 

Datasheet View  
The Datasheet View of a Table allows you to create and modify the data based on the settings of fields 
created in the Design View. 

 
  

Record 

Field 

Table 
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Design View 

The Design View of a Table allows you to create and modify fields. 

 -  Field Names (the column headings) 

 -  Data Type – Sets the type of value allowed to 
be entered into the fields. For this class we 
will use Short Text, and Date/Time. 

• Short Text allows an entry up to 255 
characters. If this is not enough you can 
use Long Text which allows for 65,536 
characters. 

• Date/Time only allow dates and times 

• Number are fields you plan to use for mathematical calculations. Values such as phone 
numbers, zip codes, and employee IDs should be left as short text.   

Beware, Number fields are automatically created as "long Integers". Change the Field Size 
property to Single or Double to allow decimal places for fields such as HA1C (6.8) or GPA (3.5).  

-  Description – your descriptions will show in the status bar of the datasheet view. 
 

Properties 
We will go more in depth with the properties in the Tables 
classes. The properties listed changed based on the data type 
chosen above. Each field has its own set of properties. 
 
The properties we will change in this class include: 
 

SHORT TEXT FIELD 
- Field Size: Number of characters allowed in a Short Text 

field 

- Input Mask: A pattern for the data to be entered. Use the 
ellipsis button (…) at the end of the line to launch the 
wizard to help create the proper code for this property. 

 

DATE/TIME FIELD 
- Format: How the value is displayed. You can choose a 

Date/Time format from the list, or use a combinations of 
M, D, Y to create your own format.  
 
Short Date: M/D/YYYY 

M=Month, D=Day, Y=Year, H=Hour, N=Minute, S=Second  
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Class Exercise 
 
Create the Database 

1. Open Microsoft Access 

2. Choose Blank Desktop Database (single click) 

3. Click on the yellow folder at the end of the 
File Name box and browse for the Desktop 

• Make a note of where you saved this file. 

4. Name the File: Access Basics 1 

5. Click Create 

 

Explore the Window 

1. Close Table1 with the X or right-click on the name of the table, chose Close 

2. Explore the Ribbon 

• Home Tab – Clipboard, Sort & Filter, Records (Spell check), Find, Text Formatting 

• Create Tab – Create Tables, Queries, Forms, Reports 

• External Data Tab – Import and Export data  

• Database Tools Tab – Advanced Features - Relationships and Data Analyzers 

 

Create the Patients Table 

1. Click on the Create Tab and choose Table Design 

 

2. Type the first Field Name: Pt Med Rec # 

• Data Type: Short Text, Description: Patient's Medical Record Number 

3. Enter in the rest of the fields (descriptions not necessary): 
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4. Set the Pt Med Rec # to be the key 

• Click on the big key on the Design tab, or right-click inside the Pt Med Rec # field 

5. Save the Table as Patients 

 

Entering First Record 

1. Turn to the Datasheet View 

• Right-click on the table name and choose Design. 

• Use the View button in the ribbon. It's on the Home tab and 
the Design tab. 

• Use the view buttons in the status bar, bottom right corner of 
the window. 

2. Enter our first Pt Med Rec #: 123-456 

3. Press tab move to the next field 
Pt Med Rec # Pt First Name Pt Last Name Pt Phone # Pt Birth Date 

123-456 Sam Franks 3525551234 1/1/1 

• Pt First Name Name: Sam 

• Pt Last Name: Franks 

• Pt Phone #: 3525551234 (all one number) 

• Pt Birth Date: 1/1/1 
− Access should add in the "200" for 2001, if it did not change, return to the Design view and set 

the Data Type to Date/Time. 

 

 

Exit the Database 

1. Exit the database, Access will probably not ask you to save 
• Access automatically saves the record, but if you changed the column sizes it will ask you to 

save the Layout. 

2. Open Microsoft Access 
• From the File menu, choose your Access Basics 1 database, If necessary, Enable Content 

3. Open the Patients table (double-click) from the navigation pane 
• Sam should still be there! 
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Rearrange Fields 

1. In Design View, move Pt Birth Date above the Pt Phone # 

• Click on the row heading, the grey box in front of the field name. Then Click/Drag the line 
above the Pt Phone # 

 

2. In Datasheet View, Enter the next record 

• Again, no separators in the phone number 

Pt Med Rec # Pt First Name Pt Last Name Pt Birth Date Pt Phone # 
789-012 Jacob Smith 2/2/92 3525554321 

 

 
 
 

Adding Fields 

1. In Design View, Insert a row above Pt Birth Date  

2. Name the field Pt Handed  

• Insert Rows from Design tab, or from the right-click menu  

3. Set the new field to be Short Text 

4. In Datasheet View, enter Right (the whole word) for both 
patients. Use the arrow keys to move between the records. 
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Enter a "trouble maker" Record 

1. In Datasheet View, enter the next record 

Pt Med Rec # Pt First Name Pt Last Name Pt Handed Pt Birth Date Pt Phone # 
555-555 Jane Williams A March 3, 1983 352-555-5555 

• Enter Pt Handed (Ambidextrous) as just one character A 

• Enter Pt Birth Date as March 3, 1983; it should change to 3/3/1983 

• Type in the hyphens for the Pt Phone Number 352-555-5555 

2. Flip between the Design view and Datasheet View 

• Notice Jane's record moves. This is because by default Access sorts by the primary key field. 
Since Pt Med Rec # is our key, every time the data is refreshed it will sort the data by the 
primary key field. 

 

 

Modify Field Properties – Field Size 

1. In Design View, set Field Size property of Pt Handed 
at the bottom of the window to be 1 

2. When you return to the Datasheet View and Save, 
you will get the following warning message saying 
data may be lost. We want this to happen, click Yes.  

 

3. Data is lost, our Pt Handed entries that were Right 
should now only read R 
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Modify Field Properties – Format 

1. In Design View, set the Format property for Pt Birth 
Date to be a Medium Date 

• Notice there is no "field size" for a date field, 
because it does not matter how many characters 
you type in, as long as it is a valid date. 

• Like Microsoft Excel, Access recognizes dashes (1-
1-2001) and slashes (1/1/2001)  

 

Modify Field Properties – Input Mask 

We will explore the Input Mask more in depth in the 
Tables class. 

1. In Deign View, set an Input Mask for the 
Phone Number 

• Click in the Input Mask Property for Pt 
Phone # 

• Click the Build button (…) at the end of 
the line to launch the wizard 

• If needed, select Phone Number 

• Click FINISH 

 

2. Fix Jane's Phone Number by taking out the extra 
dash 
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Enter a New Record 

1. Enter a new record 

Pt Med Rec # Pt First Name Pt Last Name Pt Handed Pt Birth Date Pt Phone # 
527-594 Doris Jones Left 4/4/74 3525556789 

• Try to type the whole word Left, because we limited the field size to 1, you can only enter 
the first letter. 

• Any 'valid' date format, think Excel, can be entered and Access will format it to our property 
settings. 

• The input mask should pop up as soon as you type the first number. You will not be able to 
type in letters, numbers only.  

2. Close the Table 

3. Open the Patient's Table to view the new sort order, remember it sorts by the primary key 

 

4. Close the Table 

 

Back up the Database 

1. From the File menu choose Save As 

2. Choose Back Up Database and click the Save As button 

3. Save the database with today's date 

 

Compact and Repair 

Microsoft Access files can grow very quickly, and sometimes become 
bloated. Compact eliminates unused space that Access set aside and 
you never used, or from deleted structures. Repair looks for damages 
and potential data corruption.  

1. From the File menu choose Info 

• Choose Compact and Repair  

You should do this every time you add a large amount of data, the database crashes, it begins to run 
slowly, or starts acting "funny". 
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