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Basic Access Objects 

Access consists of four main database objects: Tables, Queries, Forms, and Reports. Each object has at 
least two views, Design and "Data".  

The Design View is where we build the structure of that database object.  

The "Data" view shows the output of the data and is different for each object. Tables and Queries have a 
Datasheet View, Forms have a Form View, and Reports have a Report View, or a Print Preview view.  

• Tables store the data and feed data to the other database objects. 

• Queries are used most commonly to compile data and feed other database objects. 

• Forms are used most commonly for enter, modify and view records.  

• Reports are used most commonly to present an orderly report. 
 

Tables 

Tables store data. The Tables are the true 'database' (base of data). These need to be created and 
properly linked (related) in order to effectively use the other Access tools. Tables are the core of your 
database; everything else in Access depends on the Tables.  

The Design View of a Table allows you to create and modify: 

 -  Field Names (the column headings) 

 -  Data Type (number vs short text vs date/time…) 

 -  Descriptions, which will be displayed in the status bar in the Data view of Forms 

 -  And the Properties of each field, such as how many characters can be entered (text field size), or 
how the data is formatted (05/05/15 or May 5, 2015). 
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The Datasheet View of a Table allows you to create and modify the data within a grid structure based 
on the settings of the Design View. 

 

Vocabulary 

Field – One column of a Table common to all the records 

Record – One row of a Table containing all data about a particular entry 

Table – One set of related data 

Database – Structured collection of related Tables 

A collection of fields makes up a record. A collection of records makes up a Table. A collection of 
Tables makes up a database. 

 

Queries 

Queries show a selection of records based on criteria (limitations) you provide. Queries can pull from 
one or more related Tables and Queries. Temporary relationships can be made within the query. 

The Datasheet View of a Query looks like a Table. All data added or modified in a Query, will be saved in 
the Table. The Design View is where the structure of the Query is created. This is where we choose the 
record sources and fields and set the sort order and criteria. 

 

Record 

Field 

Table 

Record Sources – Tables and/or 
Queries containing the data 

Fields – Field names from the 
above record source and 
expressions to build new fields 

Sort Order – Order of the result, in 
order of position 

Criteria – Limitations applied to the 
final result 
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Forms 

Most Forms display one record at a time, in a formatted user-friendly view. You can build your Form so 
it will display multiple records. As you develop Forms, you can create navigation buttons, insert graphics, 
and change the colors to display everything consistently. Forms have three basic views: Design View, 
Layout View, and Form View. 
 
Your record source can be a Table or Query. If we want to *all* the patients use the Table; if we only 
want to see a subset, use a Query. 
 

 
 
The data entered or modified in a Form is automatically saved to the Table. The Table is the true 

location of the data; the Form is a "pretty" way to view/modify/create the data. 
 
For the Basics workshop, we will use the AutoCreate and Wizard buttons to make our Forms. Take the Intro to 
Forms and Reports workshop for more in depth form creation. 
 
We modify our Forms by using the Layout View to change the placement and size of the fields, and the 
Design View to add objects like command buttons to move between records, and open other database 
objects like other Forms and Reports. 
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Reports 

Reports are designed to create an organized output of data from your data. With a Report, you can 
group and summarize information. You cannot edit the data in a Report, but if you make the 
modifications in the Table, Query, or Form you will see the results when you open the Report again. 
Reports have four basic views: Report View, Print Preview, Layout View, and Design View. 
 
For the Basic Workshop we will use the wizard and AutoCreate buttons to make our Reports.  
 
The Print Preview and Report View allow you to view how the data falls into the Report.  

• The Print Preview will show you how the data falls on the page, and how it will appear when 
printed.  

• The Report view lets you see a continuous flow of the data without page breaks. 
 
The Design View and Layout View allow you to resize and move the fields.  

• The Design View allows you to add objects (like text boxes that contain formulas).  
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Class Exercise 
Create the Database 

1. Open Microsoft Access 

2. Choose Blank Desktop Database (single click) 

3. Click on the yellow folder at the end of the 
File Name box and browse for the desktop 

4. Name the File: Access Basics 2 

5. Click Create 

 
Create the Patients Table 

1. Close the Table1 Access created 

2. Click on the Create Tab and choose Table Design 

 

3. Type the first Field Name: Pt Med Rec # 

• Data Type: Short Text, Description: Patient's Medical Record Number 

4. Enter in the rest of the fields (descriptions not necessary): 

 

5. Set the Pt Med Rec # to be the key 

• Click on the big key on the Design tab, or right-click inside the Pt Med Rec # field 

6. Save the Table as Patients 
 

Enter First Record 

1. Turn to the Datasheet View 

• Use the View button in the ribbon. It's on the Home tab and 
the Design tab. 

• Right-click on the table name and choose Design 
• Use the view buttons in the status bar, bottom right corner of 

the window 
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2. Enter our first Pt Med Rec #: 123-456 

3. Press tab move to the next field 
Pt Med Rec # Pt First Name Pt Last Name Pt Phone # Pt Date of Birth 

123-456 Sam Franks 3525551234 1/1/1 

• Pt First Name: Sam 

• Pt Last Name: Franks 

• Pt Phone #: 3525551234 (all one number) 

• Pt Date of Birth: 1/1/1 
− Access should add in the "200" for 2001, if it did not change, return to the Design view and set 

the Data Type to Date/Time. 

 

 

Rearrange Fields 

1. In Design View, move Pt Date of Birth above the Pt Phone # 

• Click on the row heading, the grey box in front of the field name. Then Click/Drag the line 
above the Pt Phone # 

 

2. In Datasheet View, Enter the next record 

• Again, no separators in the phone number 

Pt Med Rec # Pt First Name Pt Last Name Pt Date of Birth Pt Phone # 
789-012 Jacob Smith 2/2/92 3525554321 
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Adding Fields 

1. In Design View, Insert a row above Pt Date of Birth  

 
2. Name the field Pt Handed  

• Insert Rows from Design tab, or from the right-click menu  

 
3. Set the new field to be Short Text 

 
4. In Datasheet View, enter Right (the whole word) for both 

patients. Use the arrow keys to move between the records. 

 

Enter a "trouble maker" Record 

1. In Datasheet View, enter the next record 

Pt Med Rec # Pt First Name Pt Last Name Pt Handed Pt Date of Birth Pt Phone # 
555-555 Jane Williams A March 3, 1983 352-555-5555 

• Enter Pt Handed (Ambidextrous) as just one character A 

• Enter Pt Date of Birth as March 3, 1983; it should change to 3/3/1983 

• Type in the hyphens for the Pt Phone Number 352-555-5555 

 

2. Flip between the Design view and Datasheet View 

• Notice Jane's record moves. This is because by default Access sorts by the primary key field. 
Since Pt Med Rec # is our key, every time the data is refreshed it will sort the data by the 
primary key field. 
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Field Size Property 

1. In Design View, set Field Size property of Pt Handed 
at the bottom of the window to be 1 

 
2. When you return to the Datasheet View and Save, 

you will get the following warning message saying 
data may be lost. We want this to happen, click Yes.  

 
3. Data is lost, our Pt Handed entries that were Right 

should now only read R 

 
 

 
 

Format Date Property 

1. In Design View, set the Format property for Pt Date 
of Birth to be a Medium Date 

• Notice there is no "field size" for a date field, 
because it does not matter how many characters 
you type in, as long as it is a valid date. 

• Like Microsoft Excel, Access recognizes dashes  
(1-1-2001) and slashes (1/1/2001)  
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Input Mask Property 

We will explore the Input Mask more in depth in the 
Tables class. 

1. In Deign View, set an Input Mask for the 
Phone Number 

• Click in the Input Mask Property for Pt 
Phone # 

• Click the Build button (…) at the end of 
the line to launch the wizard 

• If needed, select Phone Number 

• Click FINISH 
 

2. Fix Jane's Phone Number by taking out the extra 
dash after the area code (352) 

 
 
 

 

Test New Settings 

1. Enter a new record 

Pt Med Rec # Pt First Name Pt Last Name Pt Handed Pt Date of Birth Pt Phone # 
527-594 Doris Jones Left 4/4/74 3525556789 
• Try to type the whole word Left, because we limited the field size to 1, you can only enter 

the first letter. 
• Any 'valid' date format, think Excel, can be entered and Access will format it to our property 

settings. 
• The input mask should pop up as soon as you type the first number. You will not be able to 

type in letters, numbers only.  

2. Close the Table 

3. Open the Patient's Table to view the new sort order, remember it sorts by the primary key 

4. Close the Table 
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Create Query - Right Handed 
1. Close the Patient's Table 

2. Go to the Create Tab and choose Query Design  

 
3. If needed, close the Add Table window 

4. From the Navigation Pane on the left side of the window, drag the Patients table to the top half 
of the query (Table Pane). 

5. Double-click on the field names to add Pt First Name, Pt Last Name, and Pt Handed 

6. View Datasheet View 

  

 

Customizing a Query 

1. In the Datasheet view, notice the sort order is by 
Pt Med Rec #  

2. In the Design view, set Query to Sort by Pt Last 
Name Ascending 

3. Go to the Data View, patients should read, Franks 
through Williams 

4. In the Design View, set the Criteria line for the Pt 
Handed field to be "R" 

5. Close and save the Query as Right Handed 
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Create Patients Form 
1. Select Patients table from left Navigation Pane so it becomes the default data source 

2. On the Create Tab, click on the Form button 

 
3. The Form opens in Layout View 

• Place your mouse along the right border of the highlighted box (usually orange) and resize 

 
4. Right-click on the Form name and go to the Design view 

5. Right-click on the Form name and go to the Form view 

6. Create a new Right handed patient 
• Move through the records until you reach a blank one, or use the "New Record" button in 

the ribbon. 

• Make sure to leave the record, "pencils down!", move to another record or save. 

7. Save Form as "Patients" 
• Records save automatically when we move to a new record. Again this is because Access is 

set to be multi user.  

8. Close the Form  
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View the New Data 

1. Double-click the Patients table to open, view new person 

2. Double-click the Right query to open, view new person 

• If you did not close the table and/or query, you may not see the person right away. Close 
the object, and when you open them you'll see the new person, or click the Refresh button 
on the Home Tab 

Notes 

Access creates the structure of the form based on the structure of the table at that moment in time. If 
you make any structural changes like adding a new field, it will not magically appear here, you will have 
to go to the design of the form and add it. 
 
Data is saved in the table and will appear in all the database objects; formatting however can change. 
 
• PT HANDED: Still limited to one character. This is a data property so if we change the number of 

characters allowed in the table, it will carry through here. 

• PT DATE OF BIRTH: Fields can be formatted through-out the database. Once this form has been 
created, you can reformat the date and it will not change the format in other database objects. 

 

To a new field to your Form/Report 
• Go to the Design view 

• Open the Add Existing Fields (button on the Design Tab) 

• Drag field off the list 
into the Form/Report 

• If the field is not on the 
list, it's not in the data 
source.  

• If needed, modify the 
design of the table or 
query, and try again. 
Be sure to close the 
form before you 
modify the data 
source. 

 
 
  



 

Page 13 

Create Simple Report Patients 
1. Select the Patient table from left Navigation Pane so it becomes the default data source 

2. On the Create Tab click on the REPORT button 

 
3. Like the new Form, the Report opens in Layout View 

• If needed, close the extra panes like the Field List 

• The sort order here is by the order the data was entered 

4. Click on a title or data point to select it and  adjust the columns to fit the data 

• You can autofit the titles, but not the data. You can see below that the Phone # is too 
narrow for the autofit. Data lives in the tables, and doesn't really exist here, it's being 
funneled into the report when we look at the Layout, Report, and Print Preview. 

• Remember the dashed line along the side is the page break 

5. Format the columns Pt Handed and Pt Date of Birth to be centered 

• Look on the Home tab or Format tab for the Center button 

6. Resize the Page Number in the bottom right, align right 

7. Close and Save as Patients 
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Create Grouped Report Patients by Handed 
1. If needed, select the Patient table from Navigation Pane so it becomes the default data source 

2. On the Create Tab click on the REPORT WIZARD button 

 

3. Step 1 (Select fields) 

• Confirm you are using Table: Patients 

• You can use more than one data source, but this is a simple report 

• Use double arrow (>>) to move over all fields 

• Push the Next button 
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4. NEXT Step 2 (Grouping) –  

a. Group by Last name 

• Select the Pt Last Name and press the > button to Group it 

 
• Push the Grouping Options in the bottom left corner of the window and choose "1st Letter" 

 
• Ungroup all fields (no blue in the right side) 

 

b. Group by Pt Date of Birth twice 

• Grouping Options by Month & by Week 

 
• Ungroup all fields (no blue in the right side) 
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c. Group by Handed 

 

5. NEXT -  Step 3 (sorting)  

• Sort by Last Name Ascending and First Name Ascending 
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6. NEXT Step 4 (layout)  

• Layout: Outline 

• Orientation: Portrait 

• Adjusting Fields (checked) 

 

7. NEXT Step 6 (saving)  

• Patients by Handed 

• Preview the report 
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8. FINISH the wizard 

• The report opens in the Print Preview; had we chosen "Modify the report's design" we 
would be in the Design view. 

 

Modify the Report 

1. Right-click on the tab name of the Report and go to the Layout view 

2. Adjust the Pt Date of Birth field, stretching toward the Pt Med Rec # field 

• Remember to do the Title and the Data.  

• If you'd like to do both at the same time, select one and Shift-Click to select the other. 

3. Close and save the Report 

 
 

Exit Access 
1. Exit Microsoft Access 

• All of the Tables, Queries, Forms, and Reports you create are all in the same file.  

2. Find and Open the Access file 

3. Back up the database.  

• From the File menu, under Save As… 

4. Compact and Repair the database 

• From the File Menu, under Info 
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