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This workshop uses the Adobe Acrobat Pro DC edition Version 2019.021.20061. Depending on what
version and what edition you have things could look VERY different.
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Forms

We use forms all the time for gathering information. Many forms are created in programs like Word or
in a design program such as InDesign or Publisher. These forms look great and are good if you want to
print the form out and fill it in, but more frequently we want the ability of creating the forms, sending
them by email and having them filled out online and the information returned to us, either by email or
into a database. And we want everyone regardless of computer platform or operating system to be able
to have access to our forms.

In this workshop we will learn how to create the forms and how to get the responses returned by email.

Creating forms

One way to share forms across different platforms is to use Adobe Acrobat Professional. Once the static
items of the form are created in a word processor program or a design program, convert it to a .pdf file
(Adobe Portable Document File) and you are ready to add form fields.

You will have to add form fields to your To begin select a file, scan a document or start from scratch
.pdf document so it will be usable by

others. If your form has been created in

Single File
MS Word, save as a .doc file in the same coarer
folder that you plan on saving your .pdf
file. This will give you a copy of the file Create New
that can be amended and altered as

. Anth Study Plan.pdf
needed. Another way to create a form is tc»fgyne'm
to scan an existing document and create a ] A S S —
.pdf file. New to Acrobat Professional @
(Starting with Acrobat 8), is Form Field
Recognition. Form field auto detection is ON. Change
Help
Form Field Recognition
Making an interactive form is as easy as 1, 2, 3.
1. Open the .pdf form [ Create PDF
gl gl}'l]Ck Presriarf Form Eﬁ Combine Files
. oose Star
E2 ceditpoF
Now we have a fillable and interactive form. At this point we can save and ,
[ Export PDF

use it or we can further refine it and fix any problems it may have.

Organize Pages
Send for Review
Comment
Fill & Sign

Scan & OCR

SN

Protect

Prepare Form

More Tools

e I3 O
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Forms Toolbar

I Prepare Form R Select Object §ipedit T AddText [IT] Text Field Check Box (@) Radio Button  [EF] List Box [ Dropdown (58] Add Button  [i] Image Field [, Date Field ===

% Digital Signature
Barcode

A Keep tool selected
(@) Field Type Help

Tools
e Text Field - User can type in information requested.
e Check Box - User can choose one or more options.

e Radio Button - User can make a single choice among several options Combo Box - User can
choose from a list or enter custom information

e List Field - User can choose one or more choices in a list

e Combo Box — User can choose one or be allowed to enter their own text

e Button Field - Initiates actions such as clear form, submit form, print form.

e Image — User can add an image.

e Date — User can click on a drop-down arrow use the date picker.

e Digital Signature - Creates a special field to add a digital signature to the document
e Barcode Tool - Add barcode to the document

e Keep tool selected — Allows you to create multiples of the same field

FIELDS =
type The Forms toolbar appears when you open a form or choose
create or edit from the Tools > Forms pane. ~ [@ Page 1
[ Date

Fields Pane
[T Semester enrolled
With this task pane showing, you can adjust Tab order by dragging a dropping

fields into order. [ Mame

Address
Add Form Fields to the .pdf document

) [zl Phone Mumber
To add the fields to your form document:
Email Address
e click on the type of form field you want to add from the Forms Toolbar

e Bring your cursor to where on the document you want the field to B Tyr
appear [ 2yr
e Click to place the form field or drag to “draw” the field on your .
document 2 3yr
e When you are done a new Field Name dialog box opens (] dyr
Each field needs to be named descriptively and uniquely. The field name pop Internship Title

up box allows you to name the field and Show All Properties if you want to

[z Address 2
add or change other field properties

Phone Number_2
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Field Properties

Text Field Properties =

The dialog boxes for the field properties
are content sensitive, so different boxes
will be available or offer different options
depending on the field you have chosen to
add. Field Properties box offers different
tabs to choose from offering different
design attributes.

General Tab

Click on the General tab and add or edit a
name for each field and if needed a tooltip
may be added. The tooltip will pop up
when the user hovers over the field. All

General |App-earance | Opticns | Actions | Format | Validate | Calculatel

Name (GIENNEREE

Tooltip |First Mame

Common Properties

Form Field: l\c"isible -

Orientation: degrees

[C]Read Only

[l Required

fields have a General tab. The Locked
checkbox locks the field so the design

[ Locked

attributes cannot be changed unless the

Locked box is unchecked.

General | Appearance |0ptiuns | Actions | Format | Validate | Calculate|

Borders and Colors

Border Color: @ Line Thickness: | Thin

Eill Color: Line Style: | Solid
Text
Font Size:  Autoc A Text Color: @
Font: [ Helwetica v]

General |App-earance Options |Acticms | Format | Validate | Calculatel

Alignment: v

Default Value:

[V Multi-line
§crol| long text
[T Allow Rich Text Formatting

-
v characters

[T Limit of

Password
Field is used for file selecticn

Check spelling

. o
Comb of o characters

Appearance Tab

Click on the Appearance tab and choose how
you want the field to appear on the document.
Add borders and /or fill colors if desired and
adjust text font and size. The appearance tab
will appear for all field types. Auto in the Font
Size text box means the text will size to fit the
box you create and will get smaller as the user
adds more text. Set a fixed size to see a
consistent font size. Choosing fonts above the
light gray line in the font list will give more
widely available fonts.

Options Tab

In the Options section, there are several choices
of how your field will look or function. For
example: alignment, scroll text and limiting the
number of characters. If you have a text box
field where the user is to add an address you
may want to limit the state field to two
characters allowing only the abbreviation can be
entered. Your tooltip for this field may be “Enter
two- letter state abbreviation”. If you think a
majority of responders will enter a particular
value, you may set up a default that will display
on opening but allows for changes.

The options dialog box will change depending
on the type of field you are creating.
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Actions Tab
Actions can be added to form fields.

An action could be opening another file or
going to another page in a document.

An action must have both the trigger to
cause the action and the action.

Each of these items must be defined.

Use the drop down menus to define your
actions and triggers.

This might be particularly useful on button
fields.

1. Select a trigger

2. Select an action

3. Click on the add button
4

. Choose fields or files or add URL as
needed in the dialog box that opens

Text Field Properties

| General | Appearance | Options | Actions | Format | Validate | Calculatel

Add an Action
Select Action: leen aweb link vl
Acticns
Up Down Edit Delete
[ Locked

| General | Appearance I Opﬁans| Acticns | Format | Validate I -Calculate|

Add an Acticn

Select Trigger. l

) Mouse Up
Select Acticn:  Mouse Down -
Mouse Enter

Mouse i

On Focus
Actions On Blur
Up Down Edit Delete

| General | Appearance | 0pt|'ﬂns| Actions | Format | Validate | Calculate|

Add an Action

Actions

l Select Action: l Open a web link

Play a sound
Play Media (Acrobat 5 Compatible)

Read an article
Reset a form

Run a JavaScript
Set layer visibility
Showyhide a field
Submit a form

Play Media (Acrobat 6 and Later Compatible)

m

Up Down Edit
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Format Tab

The format category allows formatting of
the information that is to be entered to be
set to a specific standard.

Use the drop down menus to set these
formats.

For example, you can set how numbers
are displayed and whether a symbol
(dollar sign) is displayed.

Or a date could be formatted to display a
particular way or display date only or date
and time.

The text box field and the combo Box field
will offer this tab.

Text Field Properties

| General | Appearance | Options | Actions | Format
Select format category:
None
Date Opticns Number
Percentage
m/d Time
| m/d/yy Special
m/d/yyy) Custom
mm/dd/yy
mm/ddfyyyy
mmyy
Validate Tab

| Separator Style: ’ 123456 vl

Text Field Properties =)

| General | Appearance | Options | Actions | Format |Va||'date | Calculate|

Select format category: -

Mumber Opticns

Decimal Places:

Currency Symbel: lNone vl

Symbol Location: | Before with space

Megative Mumber Style: ] Show parentheses
[T Use red text

Example of current format: -4123.03

Use the Mumber format category to display numbers,
including currency styles.

— -

Form field information can be validated when || General | Appearance | Options | Actions [ Format | Validate | Calculate

entered by the user.

@) Field value is not validated

If a field is to have only an amount in a certain Field value is in range:

number range, that range can be entered in
the validation area.

If a number out of range is entered, a dialog

From: I Tox I

) Run custom wvalidation script:

box will open up and tell the user to try again. Edit...

Custom validation scripts can also be created

and inserted here.
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Calculate Tab | General | Appearance | Opticns | Actions | Format | Validate| Calculate L

Form fields can be used to perform some
mathematical calculations.

) Value is not calculated

@ Value is the product (x} * | of the following fields:
For example, you can calculate total cost based _

on the per item cost times the entered value of Button, Candy
the number of items.

Choose the function you need and then the (©) Simplified field notation:
fields to be used.

The functions available are:

e Sum (7) Custom calculation script:

* Product |
Edit...

e Average

e Minimum
e Maximum

Radio Buttons Radio Button Properties @

Normally user is allowed to choose only one in each _
General | Appearance | Options | Actions

area. To make this function properly, name all of the

buttons exactly the same. An easy way to .
accomplish this is to copy and paste the buttons and

create as many as you need. Right-click the original Radio Button Choice:  |Cockies 2
button and choose Edit > Copy, then right-click and

choose Edit > Paste. The new button will paste in
the middle of the document and it will need to be
moved into the correct placement. When you hover

your cursor over the field it will change to a black
arrow head. Click and drag to move the field.

Button Style:

[l Button is checked by default

[T Buttons with the same name and choice are selected in unison

Export values are the information sent to a data file To create a set of mutually exclusive
or a database. Each export value needs to be radio buttons (1., where only one can

X be selected at a time), give the fields the
different. same name but different button choices.

If you think that a particular button will be chosen
by a majority of users you can set one of the

buttons as the default. [F Locked
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Submit the Form

Once you have the form designed, you may want to have the information sent back to you electronically.
This can be done by creating a Submit Button. Create this button with the action Submit a form. Then you
can add a script if one is available or you can have the information sent back to you by email.

If you are having the information sent back to you by email; when it asks for a URL use the format (no
spaces!) mailto:youremailaddress. You could put someone else’s email here if they are supposed to get the
information also. Put a semicolon ( ; ) between each email address no spaces.

Choose the FDF Include for Export Format. If you are using a script you would put the script address here.

Use the Export Format that fits the script.

Enter a URL for this link:

mailteyouremailaddress @ufl.edu

Export Format

@ FDF Include:
Field data

[ Comments

) HTML
(") XFOF Include:

Field data
Comments

(Z) PDF The complete document

["] Incremental changes to the PDF

Field Selection

Date Opticns

i@ Al fields

1

[;
1!

i fields...

) Only these...

it
M

[ Conwert dates to standard format

Dates are submitted in
DYYYMMDD format instead of
passing the user typed values
through unchanged.

| OK | | Cancel |
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