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Macros 

In Microsoft Office, a macro is a list of instructions that can be executed from a single command. This 
tool is used to help automate repetitive tasks. Macros are recorded in the Visual Basic for Applications 
(VBA) programming language. In some programs like Microsoft Access, you have to provide the list of 
actions to perform, but programs like Word and Excel have a "learn as you go" approach. When you 
Record a Macro in Excel, the program will write the VBA code that contains every action you perform 
until you click Stop.  
 
Every action includes any mistakes you make along the way, so planning the macro is essential to 
success. It's rare to have a perfect plan the first time through, and building a macro may take many trial 
and error attempts. Knowing the shortcuts of navigating in Excel can goes a long way to a smooth Macro 
creation. 
 

Moving Between Cells 

Navigating using the keyboard  

Enter Key 
The Enter (sometimes called the Return) key will move the focus down one cell.  If you are in Edit or 
Enter mode, Excel will accept changes and move down. 

- Using the Shift key and the Enter key will move the focus up one cell. 

- Using the Ctrl key and the Enter key will accept changes and remain on the current cell. This is 
the same as clicking the  in front of the formula bar.  

- Inside a selection Ctrl-Enter will fill in the contents of the cell being edited into every cell in 
the selection. 

- Using the Alt key and the Enter key will put in a hard return; that is, it forces a cell to put text on 
a second line.  

 
Tab Key 

The Tab key moves the focus one cell to the right. If you are in Edit or Enter mode, Excel will accept 
changes and move right. 

- Using the Shift key and the Tab will move the focus one cell left. 

- Using the Ctrl key and the Tab will move you to another Workbook (another Excel file). 

- Using the Alt key and the Tab will move you to another open program on your computer. 

 
Page Up and Page Down Keys 

The Page Up and Page Down keys will move the focus of the current cell to the last visible cell on the 
previous screen, that is, it moves down one "screenful" of cells. 

- Using the Ctrl key and the Page Up or Page Down keys will move to the previous or next 
Worksheet, respectfully. 

- Using the Alt key and the Page Up or Page Down keys moves a "screenful" left or right, 
respectively. 
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Arrow Keys 
In Ready mode and in Enter mode the arrow keys will move in the direction they point: up, down, left 
and right by one cell, respectively. 

- Using the Shift key and the arrows will select a range of cells as you move. 

- Using the Ctrl key and the arrows will move the current cell to the edge of the current data 
region (where the data stops/starts). 

- Using both the Shift-Ctrl and the arrows keys will select all the cells from the current cell to 
the edge of the current data region. 

In Edit mode the arrow keys will move you up, down, left and right between the letters and lines 
within the cell (if you only have one line of text the up and down arrows have no effect). 

- Using the Shift key and the arrows will select text in that direction 

- Using the Ctrl key and the left and right arrows will move word by word 

- Shift-Ctrl and the left and right arrows will select text, word by word 

 
Home Key 

In Ready and Enter mode the Home key moves to the first column within that row. 
- Using the Shift key and the Home key will select from the current cell to the first column within 

that row. 

- Using the Ctrl key and the Home key will move to the very top of your worksheet. 

- Shift-Ctrl-Home will select from the current cell to the very top of the worksheet 

In Edit mode the Home key moves to the beginning of the cell. 
- Using the Shift key and the Home key will select from where the cursor is blinking to the 

beginning of the cell. 

 
End Key 

In Ready mode the End key turns on an End feature. You will see the "END" appear on the status bar. 
Once it's on, you can then press an arrow key and it will search in that direction for a change in the cell 
pattern (with/without data). A similar method can be used by simply using the Ctrl key and the 
directional arrow. 

- Ctrl-End moves to the last working cell on the worksheet, which is the cell at the intersection of 
the right-most used column and the bottom-most used row (in the lower-right corner) 

- Shift-Ctrl-End will select from the current cell to the last (working) cell on the spreadsheet 

In Edit mode the End key moves to the end of the cell. 
- Using the Shift key and the End key will select from where the cursor is blinking to the end of 

the cell. 

 
Escape Key 

The Esc (escape) key is the cancel button; if you are editing/entering data in a cell, escape will ignore 
any changes you have made and return you to the original data or blank cell. This is the same as 
clicking the x in front of the formula bar.  Esc will close dialog boxes such as open, save as. 
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Navigating Using the Mouse and Keyboard 

Shift-Click 
If you use Shift key and the mouse you can select a range (a set of conjoining cells). Click where you 
want to start, hold down the Shift key and click where you want to stop. Every cell in between will be 
selected. 

 
Ctrl-Click 

If you use the Ctrl key and the mouse you can select various cells (skipping ones in between). You 
cannot use these for equations but you can apply formatting (i.e. change several cells to red text). 

 
Keyboard Shortcuts 

Macros can be assigned to a keyboard shortcut. It has to be a single letter, but upper case and lowercase 
are looked at differently. This gives us 52 shortcut possibilities. The macro shortcuts will replace the 
standard shortcuts. Remember, while you may not use a shortcut, other people may use them all the 
time. For example, sometimes I see Ctrl-I assigned to Insert, when it's usually Italics. 
 

Ctrl-A – Select All (Once current range, twice 
entire worksheet) 

Ctrl-B – Toggle Bold 
Ctrl-C – Copy Selected Cells or Text 
Ctrl-D – Fill down 
Ctrl-E – Flash Fill 
Ctrl-F – Find 
Ctrl-G – Goto 
Ctrl-H – Replace 
Ctrl-I – Toggle Italics 
Ctrl-J – Unassigned 
Ctrl-K – Hyperlink 
Ctrl-L – Create a Table 
Ctrl-M – Move Table 
Ctrl-N – New Workbook 
Ctrl-O – Open Workbook 
Ctrl-P – Print 
Ctrl-Q –  Quick Analysis 
Ctrl-R – Fill to the right 
Ctrl-S – Save 
Ctrl-T – Create Table Dialog box 
Ctrl-U – Toggle Underline 
Ctrl-V – Paste 
Ctrl-W – Close Workbook 
Ctrl-X – Cut 
Ctrl-Y – Redo/Repeat the last action 
Ctrl-Z – Undo 

Ctrl-Shift-A – inserts the argument names right 
of a function name in a formula 

Ctrl-Shift-B – Unassigned 
Ctrl-Shift-C – Unassigned 
Ctrl-Shift-D – Unassigned 
Ctrl-Shift-E – Unassigned 
Ctrl-Shift-F – Format Cells dialog box - FONT 
Ctrl-Shift-G – Unassigned 
Ctrl-Shift-H – Unassigned 
Ctrl-Shift-I – Unassigned 
Ctrl-Shift-J – Unassigned 
Ctrl-Shift-K – Unassigned 
Ctrl-Shift-L – Toggle Filter 
Ctrl-Shift-M – Unassigned 
Ctrl-Shift-N – Unassigned 
Ctrl-Shift-O – Selects all cells with Comments 
Ctrl-Shift-P – Format Cells dialog box - FONT 
Ctrl-Shift-Q – Unassigned 
Ctrl-Shift-R – Unassigned 
Ctrl-Shift-S – Unassigned 
Ctrl-Shift-T – Unassigned 
Ctrl-Shift-U – Expands/Collapses formula bar 
Ctrl-Shift-V – Unassigned 
Ctrl-Shift-W – Unassigned 
Ctrl-Shift-X – Unassigned 
Ctrl-Shift-Y – Unassigned 
Ctrl-Shift-Z – Unassigned 
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Record a Macro 

From the View tab, choose Macros, Record Macro…, or from the Developer tab, choose Record Macro. 

 

 
 
The first step is to give your macro a descriptive name. You cannot use spaces, dashes, periods, or other 
special characters in your macro name. Common practice is to use Underscores ( _ ) to represent spaces, 
or to use alternating capitalization (CamelCaps). 
 
As this error message states, the name cannot already be assigned, and it must begin with a letter or 
underscore.  
 

Print_This_Sheet    ~   PrintThisSheet 
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Next is the Shortcut Key. This is optional, but if you'd like to create one, see the shortcut list earlier in 
this handout. Your keyboard shortcut will overwrite the preassigned ones. So if I decide to use Ctrl-C  to 
"clean" my data, I will no longer be able to use Ctrl-C to Copy. Consider using the capital letters instead; 
Ctrl-Shift-C is unassigned. The Ctrl is already assumed here, so you would press Shift-C to assign the 
shortcut.  
 
Excel will not warn you that the shortcut you chose is already assigned to a default shortcut, but it will if 
you have assigned it to another macro.  
 

 
 

 
 
Next decide where to store the macro. The macro has to be assigned to a workbook. The personal 
Macro Workbook should make the macro accessible from any Excel file on your computer. Assigning it 
to another file will allow it to be portable, that is you can share the file with the macro attached and 
other people can use it while that file is open on their computer. 
 

• This Workbook - This choice will attach this macro to the current Excel file, and it will only be 
accessible when this workbook is open.   
 

• New Workbook - This choice will attach the macro to a new Excel file, and will only be accessible 
when that file is open. 
 

• Personal Macro Workbook - This choice will attach the macro to the hidden Personal Macro 
Workbook. This file should be opened automatically in the background of Excel. This should 
make the macro accessible without having to open a saved file. 

 
The Description is optional, but it's good practice to explain why this macro was created and what it is 
supposed to do. This is also a great place to put who created the macro and when it was recorded. 
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Absolute vs Relative References 

We use absolute and relative references in building equations in Excel.  
 

 A B C 
1 Pay Raise 3%  
2    
3 Current Pay Pay Increase New Pay 
4 $35,000.00 =A4*$B$1 =A4+B4 
5 $42,000.00 =A5*$B$1 =A5+B5 
6 $87,000.00 =A6*$B$1 =A6+B6 
7    

 
By default, when we build an equation, it's relative to its location. When we fill or copy the equation the 
cell references change. If we want to "lock" an address, like I did above in the Pay Increase, we add the $ 
character to the address.  
 
Sometime we need to mix and match the absolute and relative references.  
 

 A B C D 
1  1.0% 1.5% 2.0% 
2     
3 Current Pay 1% Increase 1.5% Increase 2% Increase 
4 $35,000.00 =$A4*B$1 =$A4*C$1 =$A4*D$1 
5 $42,000.00 =$A5*B$1 =$A5*C$1 =$A5*D$1 
6 $87,000.00 =$A6*B$1 =$A6*C$1 =$A6*D$1 
7     

 
 
If I create the equation in cell B4: =$A4*B$1, I can fill it down and across and get the correct formulas. It 
will keep an absolute Column A, and an absolute Row 1, but the other parts of the equation change to 
be relative to the row and column changes.  
 
In a Macro 
The Absolute vs Relative Reference in a macro behaves in a similar way.  If I start the Macro in cell A1, 
and I click in cell B1, how should Excel record that? Do you mean Absolute - always go to cell B1, no 
matter where you start, or do you mean Relative - go one cell to the right? When you fill to the bottom 
of the list, do you mean Absolute – Fill A1:A4, or do you mean Relative – Current cell to the bottom of 
the existing list? 
 
You can turn this option on and off on the Macros menu in the View tab, or the Code group of the 
Developer tab.  
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Stop Recording 

Once you have started recording your macro, the Record Macro button 
on the Developer and View tabs will change to say Stop Recording. 

 
A Stop Recording button will also appear in the status bar at the bottom of the window. Click on any of 
the square buttons to "Stop" recording. 
 
The only indication that Excel has stopped following you is these buttons will go away. 
 

Running a Macro 

Open the Macro window using the Macros button on the View tab, or the Developer tab. 
 
Choose the Macro you want, and click the Run button. 
 

 
 

If you assigned a keyboard shortcut, you can press that key 
sequence to run your macro.  
 
You can assign  a keyboard shortcut after the macro is created. 
From this window, choose the macro and click on the Options 
button. 

 
You can also create a button to run the macro.  
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Create a Button 

You can create a button to run your Macro for the Ribbon or the Quick Access Toolbar. Open the Excel 
Options from the bottom of the File men, or by right clicking on a tab in the Ribbon and choosing 
Customize.  
 
Change the Choose commands from: option to Macros. 
 
Select the Macro you want and click the Add button. If you are customizing the Ribbon, you will need to 
choose a tab 

 
 
Use the Up and Down arrows on the side to rearrange the order 
of the buttons 
 
Use the Modify button to change the shape of the button.  
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Editing a Macro 

Open the Macros window from the 
View tab or Developer tab. 
 
Click on the Macro name and click 
the Edit button.  
 

Personal Macro Workbook 

If the file is in the Personal Macro 
workbook you will not be able to edit 
the macro until you unhide the file.  
 
From the View tab, choose Unhide 
(it's next to Freeze Panes). Don't 
forget to hide the file again before 
you exit Excel.  
 
To avoid the unhide/hide issue, I 
usually click the Step Into button. 
 

VBA Code 

As you record you Macro, Excel writes the Visual Basic for Applications (VBA) code. When you Edit or 
Step Into the macro, Excel will show you the VBA Code. I'm not going to teach you VBA, but I will offer 
some tricks that might help. 
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Helpful Hints 
 
1.  Place a single quote ( ' ) in front of a line of 

code to "comment" it out, this means this line 
will not run. It's also a nice way to add notes to 
each section of your macro.  

 
2. Macros begin with SUB, and stop with END 

SUB. Sometimes it's useful to combine macros. 
Perhaps you forgot a step, you can create a 
temporary macro, do the step. Stop the 
recording, and edit/step into the code, copy 
and paste it into the other macro. 

 
For example, the macros on the previous page, 
bold first row and Freeze top row, can be 
combined by deleting the close macro in 
Bold_Titles (End Sub) and the opening of 
FreezeTop ( Sub FreezeTop() ). 

 
3. To Delete a macro from this window, select the Sub to End Sub, and press delete or backspace.  

 
4. To Rename a Macro, change the text next to Sub at the top of the code. 

 
5. "Step Into" lets you run the code one line at a time. You can find the option under the Debug menu, 

or use the keyboard shortcut - function key F8. 
 
Rearrange the windows on your screen to show Excel and the VBA Code at the same time.  In the 
VBA window, press F8 and watch the Excel Window as Excel runs the code one line at a time, with 
each "step into" action. Excel will highlight the line that will be run with the next Step Into.  

 

 
 

6. When in doubt, throw it out. Sometimes it's just easier to delete the macro and remake it. 
 

7. PLAN your macro. Remember that Excel records everything you do, including the mistakes. Feel free 
to contact me to help with simple macros. 

 
8. Microsoft Help: Run a macro - Office Support (microsoft.com) 

https://support.microsoft.com/en-us/office/run-a-macro-5e855fd2-02d1-45f5-90a3-50e645fe3155?ns=excel&version=19&syslcid=1033&uilcid=1033&appver=zxl190&helpid=20942&ui=en-us&rs=en-us&ad=us
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Class Exercise 

Open Excel 
 
Discuss Personal.xls vs. This Workbook 
 
Open KRats01.txt, click Finish 
 
Record New Macro 

- View Tab -> Macros -> Record Macro 
o Name: CleanRat 
o Save in personal.xls 

- Select Column B, Format Date 
- Select Column D, Format number one decimal 
- Select Row 1, Bold 
- Select All, Autofit Columns 
- Control-Home 
- STOP 
- Close without saving 

 
Test Macro 

- Open KRats01.txt, click Finish 
- Run the Macro 

 
Make a Button 

- Customize Quick Access Toolbar 
- More Commands 
- Choose Commands From: Macros 
- Find your macro 
- Add >> 
- Select the Macro 
- Modify… Button at the bottom of the pane 

 
Test button  

- Open KRats02.txt, click Finish 
- Run the Macro 
- Open KRats03.txt, click Finish 
- Run the Macro 
- Close All without saving 

 
Remove Button  

- Right-click on button to remove from quick access toolbar 
 
Delete Macro 

- View Tab ->Macro->View Macros 
- Try to delete CleanRat 
- Click ok to error, and cancel 

 
- View Tab -> Windows->Unhide->Personal.xls 
- Tools->Macro->Macros 
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- Delete CleanRat 
- Windows->Hide 

Create a new Worksheet 
 
Talk about moving around excel using the keyboard. 

- Practice with Ctrl arrows 
- Practice with Shift-Ctrl arrows 

 
Turn on Developer Tab 

- Right-click on the ribbon 
- Choose Customize Ribbon 
- Turn on checkbox for Developer 

 
Create new macro 

- Developer Tab -> Record Macro 
o Macro Name: Test 
o Shortcut Key: Ctrl-q 
o Store Macro in: This Workbook 

- B2: abc – blue 
- C3: def – red 
- D4: 123 – green 
- STOP 

 
Run Macro 

- Move to Sheet 2 
- Run Macro twice (ctrl-q) 
- Move to Sheet 3 
- Run Macro (ctrl-q) 

 
Close and don't save the file. 
 
Create new macro 

- Developer Tab -> Record Macro 
o Macro Name: Test 
o Shortcut Key: Ctrl-q 
o Store Macro in: This Workbook 

- Developer Tab: USE RELATIVE REFERENCES 
- B2: abc – blue 
- C3: def – red 
- D4: 123 – green 
- STOP 

 
Run Macro 

- Move to Sheet 2 
- Run Macro three times (ctrl-q) 

 
Close and don't save the file. 
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Open Customers.xls 
 
Create Macro 

- Click on Worksheet K 
- Tools->Macro->Record New Macros... 

o Name: Consolidate 
o Save in this Workbook 
o assign Ctrl-q 

- relative off 
- Ctrl Home 
- down one cell, shift-ctrl-down, shift-ctrl-right 
- copy 
- Click on Sheet J 
- Ctrl-Home 
- Ctrl-down 
- down 
- paste 
- Ctrl-Home 
- STOP 

 
Test macro 

- Click on Worksheet L 
- Ctrl-q 
- Click on Worksheet M 
- Ctrl-q 

 
Close without saving 
Open Customers.xls 
 
Create Macro 

- Click on Worksheet K 
- New Macro 

o Name: Consolidate 
o Save in this Workbook 
o assign Ctrl-w 

- Use Relative References  
- Ctrl Home 
- down one cell, shift-ctrl-down, shift-ctrl-right 
- copy 
- Click on Sheet J 
- Ctrl-Home 
- Ctrl-down 
- down 
- paste 
- Ctrl-Home 
- STOP 

 
Test macro 

- Click on Worksheet L, Ctrl-q 
- Click on Worksheet M, Ctrl-q 
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