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Sorting Data 
On the far right side of the Home tab, you will find a large Sort & Filter 
button. The menu you see when you Click on the button is reflected in 
the Sort & Filter group of the Data tab. 
 

If you make a selection of cells, 
Excel will think you only want to 
sort or filter by that selection. But if 
your dataset has no blank rows and 
no blank columns Excel will see the 
whole range as one dataset. 

 

The dataset can have blank cells, but not completely blank columns/rows; if you are not sure that your 
dataset is consistent, click inside one cell, and press Ctrl-A. This will select all the cells within the dataset. 
A second "Ctrl-A", or pressing the shortcut in an empty cell, will select the entire sheet. 
 

When you have completed a sort, you can Click the Undo button (or Ctrl-Z). Excel will undo the sort and 
it will select the dataset it used in the sort.  
 
Ascending Sorts 

-  Text: Sort alphabetically from A to Z 
- Numbers: Sort from smallest number to largest number 
- Dates: Sort from the oldest date to the newest date 

 
Descending Sorts 

- Text: Sort alphabetically from Z to A 
- Numbers: Sort from largest number to smallest number 
- Dates: Sort from the newest date to the oldest date 

 
Custom Sorts 
When you first open this window, Excel will show the most recent sort options. If you have not created a 
sort yet, this window may be blank. If you were expecting your titles (First Name, Last Name…) instead 
of the column headings (Column A, Column B), click the My data has headers option. 
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Column: The column drop-down menu will show the names of your 
columns, your 'fields'. If your data does not have titles, Excel lists the 
column heading letters instead.  
 
Sort On: You can Sort on the values of the cells, the cell colors, the font 
colors, or the cell icons. 

 
Order: The order options change depending on the values in the cells.  
 
 Text Number Date 

   
 Font Color Cell Color 

   
 
Custom Lists 
Custom lists can be built through the 
Excel Options under the File menu in 
the Advanced section under General. 
Or by choosing Custom List… option at 
the bottom of each order box above.  
 
If you choose this option, you will be 
able to select from one of these lists. 
Alphabetically, April comes before 
January. With the Custom List order, we 
can ensure January comes first. 
 
These custom lists will work as patterns 
with the fill handle. Notice the 
"Shopping" list? Once I set this up, I can 
type any of the words in a cell and use 
the fill handle to follow this pattern.  
 
 
Sort Options 
- Case sensitive: Sort lowercase letters before uppercase letters 
- Orientation: Sort vertically (top to bottom, sort rows) or horizontally 

(left to right, sort columns) 
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Filtering Data 
Filters hide rows (records) based on your criteria. You can turn the filter on 
and off by choosing Filter from the Sort & Filter button on the Home tab, or 
choosing the Filter button on the Data tab.  
 
Excel will place a drop-down arrow at the end of each cell in the title row 
(the first row of the dataset). When you Click on this arrow, we see several 
options including our sort orders: 

• Sort Ascending, Descending, and by color 

• Clear the Filter from this column 

• Filter by Color 

• Set a custom filter (text, number, date) 

• Search for a matching value in the column 

• List of values in the column (field). Select All will toggle 
between everything and nothing.  

Once a filter has been set Excel will hide all the rows that do not match the criteria. The status bar will 
show how many records (rows) were found that matched. The row numbers of the original data will 
remain the same, but will appear blue. The dropdown arrows of the columns that are being filtered will 
show the filter icon (funnel). The double line between the row numbers indicate hidden rows. 
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Custom Filters 
Depending on the data in the column, you will have the option to set a custom filter based on text, 
numbers, and dates. 
 
  Text Filters Number Filters Date Filters 

     
 
If you choose one of the options on the Filter List with the ellipsis (…), you 
will see a Custom Auto Filter window such as this. From here, we can set up 
to two filters. 
 

 
 
Be careful with the AND/OR relationships. If you ask Excel to show the rows where the City equals 
Jacksonville AND the City equals Gainesville, you will get no results, because one cell cannot equal both 
values. However, if you ask for the same using the OR, Excel will show all the records for both cities. Or's 
tend to work for exact matches (Equals This OR Equals That), whereas AND's tend to work for ranges 
(Greater than This AND Less than That). 
  
You can use the "Wildcards" ? and * to help you with your filter. ? is used for one character, * for 
multiple. 

Equals Jacks* -> Jacksonville, Jacksonville Beach, Jackson Heights 
 
The Search option on the filter menu is a "contains" filter. When you type in the Search the results on 
the filter menu becomes a shorter list. 
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Class Exercise Sort 
 
- Open file SortCustomers.xlsx 
 
Simple Sorts 
 - Click in the title CITY in cell D1 

 - Home Tab -> Sort and Filter -> Sort A to Z (ascending) 

 - Undo  

  - Sort is "undone" and sorted dataset is selected 

 - Select Column D (City) 

 - Home Tab -> Sort and Filter -> Sort A to Z (ascending) 

  - Say OK to the message 

 - Undo 

 

Default Sort Order 
 - Right-Click Column A (LAST) 

 - Insert a Column 

 - Title the new column SORT (A1) 

 - In A2 type:  1 

 - In A3 type:  2 

 - Select both numbers 

 - Double-Click the fill handle to copy the pattern to the end of the dataset 

 - Sort by column CITY 

 - Sort by column SORT 

 - Delete Column A 

 

Blank Columns (every column should have a heading) 
 - Select Column B (FIRST) 

 - Insert a Column 

 - Sort by CITY Z to A (descending) - Notice the first and last names no longer match up 

 - Undo - Notice the last name column is left out of the selection 

 - In B1 type: SUFFIX 

 - Sort by City Z to A 

 - Undo until the new column (SUFFIX) is gone 
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Custom Sort  
Multiple levels 
 - Click on the large sort button on the Data tab  

 - Set the sort order for CITY, BALANCE, and DUE DATE 

  - Use the Add Level buttons to create new lines 

 - View the Results 

 

Custom Sort - Rearranging 
 - Open the Custom Sort again 

 - Select the DUE DATE row and use the arrows to move it 

 - Set the sort order for 
CITY, DUE DATE, and 
BALANCE 

 - View the Results 

 

 

 

 

 

 

Custom Sort - Resetting 
 - Click in the Column A (LAST) 

 - Click the Ascending button  

 - Open the Custom Sort window 

  - Sort order has been reset 
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Custom Sort - by Color 
 - Open the Custom Sort window 

 - Sort by Address, Sort on Cell Color, Order Green "On Top" 

 - Copy Level and set the Order to Peach "On Top" 

 - Add Level -> Balance, smallest to largest 

 - View the Results 

 

Reset to our default sort order 
 - Click in the column A (LAST) 

 - Click the Ascending button  

 

Custom Sort - Left to Right 
 - Open Custom Sort Window 

 - Click on the Options… button 

 - Change orientation to Sort left to right 

 - Click OK 

 - Sort by Row 1, A to Z 

 
 - Columns should rearrange to Address through Zip 
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 - Select Row 2, and Insert a row 

 - Number the cells: 3, 8, 4, 7, 1, 2, 5, 6 

 
 - Open Custom Sort Window 

 - Sort by Row 2 

 - View the result 
 

Custom Sort - Left to Right - Selection 
 - Select Columns A and B (FIRST and LAST) 

 - Open Custom Sort window 

 - Sort by Row 2, Largest to Smallest 

 - Repeat for Columns G and H (DUE DATE and BALANCE) 

 - Delete Row 2 
  

Reset to our default sort order 
 - Open Custom Sort window 

 - Open Options…  

 - Change to Sort top to bottom  
 

My data has headers 
 - Sort by only lists the column letters for the 8 columns in our dataset 

 -  In the upper right of the window Click the My data has headers checkbox 

 - Sort by LAST, A to Z 

 

Start over 
 - Exit Microsoft Excel  

 - DO NOT SAVE  
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Class Exercise Filters 
Quick Filter 
 - Open SortCustomers.xlsx 

 - Right-Click on a city of Waldo 

 - Choose Filter -> Filter by Selected Cell's Value 

 
*** Filter arrows appear on all columns of the dataset 
*** All rows not matching the criteria have disappeared 
*** Row numbers turn blue, but maintain original row numbers 
*** Status bar shows how many records (rows) match the criteria 
 
Turn the Filter Off 
 - From the Sort & Filter button on the Home tab, choose Filter 

 *** All filter signs will disappear 

 
Filter with Check Boxes 
 - Click the large Filter button on the Data tab 

 - From the City drop down, uncheck Jacksonville, Click OK (67 records) 

 - From the City drop down, uncheck Gainesville, Click OK (12 records) 

 - From the City drop down, check Select All, Click OK 

 
Filter by (Un)Select all 
 - from the Zip drop down 

  - uncheck Select All 

  - check 32608 

  - Click OK (12 records) 
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More than one filter 
 - Keep the 32608 filter 

 - from the City drop down, uncheck Jacksonville 

 - Click OK (9 records) 

 - from the Data tab, choose the filter Clear button 

 

Custom number filter 
 - Balance drop down 

 - choose Number Filter 

 - choose Less than, type in 100 

 - Click OK (12 records) 

 - Clear the filter 

 

Date filter 
 - Due Date drop down 

 - uncheck Select All 

 - use the expand (+) buttons to open the dates 

 - check the first three months of 2016 

 - Click OK (11 records) 

 

 

 

Custom date filter 
 - From the Due Date drop down, choose Date Filters 

 - Choose Between 

 - type in 7/1/2016, type in 6/30/2017 

 - Click ok (23 records) 

 - Clear the filter  
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Custom text filter AND/OR 
 - From the Last drop down, choose Text Filter 

 - Choose Begins with, type J 

 - Click ok (10 records) 
 
 - From the Last drop down, choose Text Filter 

 - Choose Ends with, type S 

 - Click ok (21 records) 

 
 - From the Last drop down, choose Text Filter 

 - Choose Begins with, type J 

 - On the second line choose Ends with, type S 

 - Click ok (6 records) 

 
 - From the Last drop down, choose Text Filter 

 - Choose Custom Filter 

 - Change the bubble (radio button) to OR 

 - Click ok (25 records) 

 
 - Clear the filter 

 
Custom text filter Contains 
 - From the Address drop down, choose Text Filter 

 - Choose Contains, type Box 

  - Excel is not case sensitive. BOX = Box = box 

 - Click ok (12 records) 

 - Clear the filter 

 

Search filter 
 - From the Address drop down, Click inside the Search box 

 - Type box 

 ****  Type it slowly, one letter at a time to see the list 
get smaller as you go 

- Click ok (12 records) 

 - Clear the filter 
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Filter by Color 
 - From the Address drop down, choose Filter by color 

 - Choose the green addresses (13 records) 

 - Clear the filter 

 

Refreshing Filtered Data 
 - From the Balance drop down, choose Number Filter 

 - Choose Greater Than, type 600 

 - Click ok (4 records)  

 - Change Edgar's balance to 300 

 - From the Data tab, choose the filter Reapply button (3 records) 

 - Clear the filter 

 

Copying Filtered Data 
 - Use the filter tools to find these 9 records: 

  - Balance under 400 

  - Address color has no fill 

  - Due Date in 2019 

 - Select All, Copy 

 - Create a new worksheet 

 - Paste in Cell A1 

- Return to Sheet 1 and Clear the filter 

 - Use the filter tools to find these 10 records: 

  - Balance under 300 

  - Address color has no fill 

  - Due Date in 2020 

 - Select All, Copy 

 - Turn to Sheet 2 

 - Paste in Cell A12 

 

  

 
 

- In Sheet 2, Select ALL of the sheet 

 - AutoFit the column widths 

  - Double-Click between column headings
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Filter one dataset 
 - Move to Cell A1 (Ctrl Home) 

 - Turn on the filter 

 - From the City drop down, uncheck Gainesville 

 - Click ok (4 records) 

  ****Gainesville only disappears from the first list because of the gap 

 - Turn off the filter 
 

Filter multiple datasets 
 - Select all the data columns (not just the data, all the columns A:H) 

 - Turn on the filter 

  - AutoFit again 

 - From the City drop down, uncheck Gainesville 

 - Click ok (6 people) 

  ****Gainesville disappears from both lists, but the record count is wrong 

 - Clear the filter 
 

Filter including gap 
 - From the City drop down, uncheck Select All 

 - From the City drop down, check Gainesville 

 - From the City drop down, check (Blanks) 

 - From the City drop down, check City 

 

 - From the City drop down, uncheck Gainesville 

 - From the City drop down, check Jacksonville 

 

 -Turn off the filter (not just clear) 
 

Multiple filters using Tables 
 - Move to the first dataset 

  - From the Home tab, choose Format as Table, pick one and click OK 

 - Click in the second dataset 

  - From the Home tab, choose Format as Table, pick one and click OK 

 - Both Tables have filters 

(More on Tables in the Conditional Formatting session!) 
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