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Number of Worksheets
By default, new workbooks only have one worksheet, but you can change the default setting from the
Excel Options. The Options button is at the bottom of the File menu. In the General group of the Excel
Options, you can set the number of sheets to be opened in a new workbook.

You can set new books to start between 1 and 255 sheets. Changing this setting will not modify the
current workbook, only future *new* workbooks.
Inserting Worksheets
You can insert a worksheet by doing one of the following:
 Click on the Insert Sheet button located at the bottom of the window. The new sheet will be
inserted after the selected worksheet.

 or Press Shift-F11 on the keyboard.
 or from the Home tab, the Cells group, Insert, Insert Sheet.
 or Right-click on the name of any sheet and choosing Insert… Excel will then
ask what you want to insert. Choose Worksheet and click OK.
To insert multiple sheets at once, select the number of worksheets you would like to
insert and follow the steps above. If three sheets are selected when you insert a
worksheet, then three new sheets will be inserted. See Selecting Multiple
Worksheets later in this handout.
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Deleting Worksheets
You can delete a worksheet by doing one of the following:
 Right-click on the name of the worksheet and choose Delete.
 or from the Home tab, Cells group, Delete, Delete Sheet
If the worksheet is empty it will be deleted, otherwise Excel will ask you to confirm the deletion.

Note that the message says, "To permanently delete…" Once you confirm this deletion there is No
Undo. The sheet, and everything on it is gone. The Undo menu is also cleared, so you can't undo any
actions before the delete.
To delete multiple sheets at once, select the worksheets and follow the steps above. See Selecting
Multiple Worksheets later in this handout.
Renaming Worksheets
You can rename a worksheet by doing one of the following:
 Double-click on the name of the worksheet.
 or Right-click on the name of the worksheet and choosing Rename
 or from the Home tab, Cells group, Format, Rename Sheet.
However, you choose to rename, the worksheet name will be selected.

Type the new name and press Enter on the keyboard to accept it.
Press Esc on the keyboard to cancel renaming the sheet.
Your worksheet name can contain up to 31 characters. There are a few
characters that Excel won't let use in the sheet name.
Examples: Asterisk ( * ), Backslash ( \ ), Colon ( : ), and Brackets ( [ ] )
Color Coding Worksheets
You can change the color a worksheet:
 Right-click on the name of the worksheet and choosing Tab Color.
 or from the Home tab, Cells group, Format, Tab Color.
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Moving and Copying Worksheets
A worksheet can be moved by dragging it to a new location. Click on the worksheet name, don't let go,
and drag the worksheet left or right to the new location. When you are holding onto a worksheet, your
mouse cursor will show a sheet of paper and a little black arrow will appear above the sheets, this black
arrow will show you where the new worksheet will be when you let go of the mouse.

If you hold down the control (Ctrl) key while moving the worksheet, you can create a duplicate, a copy
of the worksheet. This copies everything, all the contents and formatting. (Remember to let go of the
mouse before letting go of the keyboard.)

For more options do one of the following:
 Right-click on the sheet name and choose Move or Copy...
 or from the Home tab, in the Cells group, choose Format,
and choose Move or Copy Sheet
The window that comes up allows you to choose a where you
would like to place the sheet in the current workbook, or any open
book (under the To Book: menu). This includes an option to create
a new Excel workbook (new book).
By default, this window will move the worksheet; click the check
box at the bottom of this window if you would prefer to create a
copy.
Hiding Worksheets
For some templates and lookup files you may wish to hide a
worksheet.
 Right-click on the name of the worksheet and choosing Hide.
 or from the Home tab, in the Cells group, choose Format,
choose Hide & Unhide, and choose Hide Sheet.
Unhiding Worksheets
Unhide a worksheet:
 Right-click on the name of any worksheet and choosing
Unhide….
 or from the Home tab, in the Cells group, choose Format,
choose Hide & Unhide, and choose Unhide Sheet…
To prevent people from unhiding the worksheets, protect the
workbook from the Review tab.
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Selecting Multiple Worksheets
The Shift and Ctrl keys on the keyboard allow you to work with multiple selections. You can use them to
select multiple shapes, multiple cells, and multiple worksheets.
With multiple worksheets selected you can:
- Enter data on the current sheet and it will be entered on the selected worksheets
- Enter formulas on the current sheet and it will be entered on the selected worksheets
- Change formats on the current sheet and it will change on the selected worksheets
- Insert multiple worksheets
- Delete selected worksheets
- Color selected worksheets tabs
- Move selected worksheets
- Change the Page Setup for selected worksheets
- Print selected worksheets
Range of Worksheets
To select a range of worksheets, use the Shift key.
1. Click on the first worksheet
2. Hold down the Shift key on the keyboard and click on the last worksheet
If we click on 1st Qtr and Shift-click on 3rd Qtr, we will have all three sheets selected.

Selecting Specific Worksheets
To select specific worksheets, use the control key.
1. Click on the first worksheet
2. Hold down the Ctrl key on the keyboard, and click on the second worksheet
3. Keeping the Ctrl key pressed, click on each worksheet you would like to select
If we click on 1st Qtr and Ctrl-click on 3rd Qtr, we will have only those two sheets selected.

Selecting All the worksheets
 To select all the worksheets, click on the first sheet and shift-click on the last sheet.
 Or right-click on any worksheet name and choose Select All Sheets.
Unselecting Worksheets
To drop the selection, click on a worksheet that is not part of the current selection. Or right-click on any
worksheet name and choose Ungroup Sheets.
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Linking Cells
Linking cells is one of the operations in Excel that is so simple, it's hard to believe. When you create the
Link, Excel will enter the path and keep track of the moments of the original cell.
Create a Link
Click inside the cell where we want the answer, press the Equal ( = ) key on the keyboard, as if we were
going to build an equation, and then click on the cell we want to link to, putting Excel into a "Point"
mode. Click on any cell on the worksheet, on another worksheet, and even in another workbook.
Link to cell A1
Press the equal button on the keyboard. Click in cell A1. Press Enter on the keyboard.

Link to Cell A1 in Sheet2
Press the equal button on the keyboard. Click on Sheet 2, click in cell A1. Press Enter on the keyboard.

Link to Cell A1 in Sheet1 of Book2
Press the equal button on the keyboard. Click on Book2, Sheet1, cell A1. Press Enter
on the keyboard.

Using the Clipboard
Another way to create a link is to copy the original data, move to where you would
like the linked value to appear and choose "Paste Link". Paste Link can be found on
the Paste drop-down list, the right-click menu, and as an option in the Paste Special
window. The icon looks like a small chain link.
Remove a Link
To break the link, delete the contents of the cell. To keep the values, copy and Paste values. To remove
all the links and keep the values, see the Edit Link Window section of this handout.
Absolute vs. Relative Links
When you link to a cell in the same workbook Excel creates a "relative" link. When the link is to another
workbook it creates an "absolute" link. You can see this by the dollar signs ($) around the cell address.
You can type in or remove the dollar signs to change between the two options. F4 is the keyboard
shortcut to toggle between the absolute/relative options.
Excel will follow the address of the original data whether we are set to Relative or Absolute. However, if
we are using different workbooks, Excel can only follow the data while the other book is still open. If
data moves in another book, and the linked file is not open, the cell links will not follow the new
addresses, even after an update.
The Absolute and Relative settings will matter when you try to copy or fill the link. With the Absolute ($),
the copy/fill will contain the same cell addresses (i.e. $A$1-$A$1-$A$1…); with the Relative (no $), the
copy/fill will contain the series (i.e. A1-A2-A3…)
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Linking Workbooks
As stated on the previous page, linking workbooks is as simple as linking worksheets, with the added
step of choosing the file first. Click in the cell where you want the result to be, press the equal sign (=) on
the keyboard and then use your mouse to select the workbook, click on the worksheet, click on the cell
you want to link to and press Enter to accept.
The formula bar will show the full path of the linked cell. If the file is open you will see just the file name,
worksheet name and cell address.

If the linked file is not open, you will see the location of the file as well:

Opening Linked Files
The safest way to work with linked files is to have the original data and the linked files open when you
move things around. However, that's not always feasible.
Case 1: Open the original file and then Linked file
Result – Excel sees the links and updates all changes and will continue to update you go.
Case 2: Open Linked file by itself (or before the original)
Result – Excel prompts for permission to update links. Depending on your security settings you
may see the subtle yellow security message between the ribbon and the formula bar, or the
warning message box forcing you to choose.
If you ignore the message, you can continue to work in Excel with the 'old' data.
If you click Enable Content Excel will update the links, if it can find the original file.

If you click Don't Update you can continue to work in Excel with the 'old' data.
If you click Update Excel will update the links, if it can find the original file.
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Handling Broken Links
Excel does a wonderful job updating the links, IF it can find the cell you are referring to in your dataset.
If the filename or sheet name has changed while the linked file is open, the links will be able to follow
along, however, if they are changed while the linked file is closed Excel will lose its way.
When you ask Excel to update the link, if it has a problem it will prompt you:

If you Continue, you can work with the "old" data.
If you click Edit Links… you be able to modify where the source file is located.

Click on the Change Source… button to find the original file. If the
worksheet names have changed, the Status error will read "Error:
Worksheet not found". For missing worksheets, it will prompt to find the
sheet name.
Removing all links
If the original file or sheets have been deleted, you may need to use the
Break Link option. This will convert all the linked cells to values. This
option cannot be undone.
Edit Link Window
You can open the above Edit Link window at any time from the Data tab, in the Connections or
Query/Connections group.
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Working with Multiple Files/Windows
Keyboard Shortcuts
• Alt-Tab – Switches between open programs
• Ctrl-Tab – Switches between open windows in a program. This doesn't work with all of them,
but it will in Excel and most web browsers.
• Windows key ()-M – Minimizes all windows, takes you to the desktop
• Windows key ()-L – Moves the current window to the Left side
• Windows key ()-R – Moves the current window to the Right side
• Windows key ()-Up Arrow (↑) – Moves the current window to the Left side
Ungrouping Taskbar Buttons
Your copy of Windows may try to lump all of the files into the same icon across the task bar at the
bottom of the window.

But you may prefer to see them split out into individual buttons.

To do this, right-click in an empty space on the
Windows Taskbar and choose Properties.
Change the option Task Bar Buttons from "Always Hide
Labels" to either of the other options.
The When taskbar is full option will group the buttons
together when the taskbar is crowded; Never will keep
them separate even if there is almost no room for them.
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Moving Between Windows
We can use the Task Bar to move between our files, or we can use the keyboard shortcuts.
These can be tedious if there are a lot of files open. To see a list of all the open Excel files, turn to the
View tab. In the Windows group you will find a list of the open files under Switch Windows.

View Different Sheets of the Same Book
The New Window option on the View tab will open another window of the same Excel file. This allows
you to look at two different worksheets of the same Excel file!
Microsoft Excel no longer allows you to open multiple files in the same instance of Excel, each Excel
window will open with its own ribbon. Excel's Arrange All button should work with all the open Excel
windows, but you can right-click in the Windows Taskbar to find window arranging options.
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Class Exercise
Review
-

Open Excel

-

File->Options
o

Default # of sheets

Rename Sheets
-

Double-click on the worksheet name Sheet1
o

-

o

Press enter to accept

o

Sheet2 -> 2nd Qtr

o

Sheet4 -> 4th Qtr

Insert three more sheets and Rename

o

-

Rename to 1st Qtr

Keyboard Shortcut:
Shift-F11 = New Sheet

Sheet3 -> 3rd Qtr

If needed, drag the worksheet names to put the sheets in order

Label the sheets
-

For each sheet, In Cell D1 Type name of worksheet
o

o

Click on 1st Qtr sheet, click in Cell D1, type 1st Qtr
Repeat for each sheet, 2nd Qtr, 3rd Qtr, 4th Qtr

Modify multiple sheets
-

Click on 1st Qtr sheet, Shift-Click on 4th Qtr sheet

-

Zoom 150%

-

View each worksheet

Modify specific sheets
-

Click on the 1st Qtr sheet

-

Ctrl-Click on the 3rd Qtr sheet
o
o

Click in Cell D1
Use the Fill bucket to change the color

-

Click on the 2nd Qtr sheet

-

Ctrl-Click on the 4th Qtr sheet
o

-

o

Click in Cell D1
Use the Fill bucket to change the color

View each sheet
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Keyboard shortcut:
Use Ctrl-Page Up and
Ctrl-Page Down to move
between the worksheets.

Enter data on multiple sheets
-

Click on 1st Qtr sheet

-

Right-click on the sheet name and choose Select All Sheets

-

o

Check title bar for [Group]

o

A1: Big City Store

Type:

o

A2: Quarterly Sales Report

-

View each sheet

-

Select All Sheets again

-

Create the table show here:

Format multiple sheets
-

Bold Titles and place a bottom border

-

Accounting ($) format Price & blank Total cells

-

Center Qty

-

Create formula for Total for Item A
o

=B5*C5

-

Use Fill handle to create equations for Items B & C

-

In cell C8: "Quarterly Total:"
o

Right Align

-

In Cell D8: Use AutoSum button to total

-

View Other sheets
o

Shortcut: Click on
Column B (Price) and use
the Ctrl key to select
Column D (Total). Format
them at the same time.

Make sure all the sheets are now
unselected (no [Group] in title bar)

Adjusting formatting
-

On the 1st Qtr sheet:
o

o

Type in Cell C5: 987
Notice the Column is too Narrow ########

-

Select all sheets

-

Expand Column D, wider than the autofit. Give enough room for a million dollars

-

Type in Cell C6: 654

-

Turn to 2nd Qtr sheet

Fix multiple sheets
-

Click on 2nd Qtr Sheet, shift-click on 4th Qtr Sheet

-

Click in cell C6 (the 654), press delete to remove unwanted data

-

Click on 1st Qtr Sheet, Confirm lack of [Group] in title bar

-

Type in Cell C7: 321
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Create a Total's Page
-

Insert a worksheet

-

Move it to Beginning
o

Drag Sheet5 to the beginning of the worksheets

-

Name it Totals

-

Increase the Zoom to 150%

-

Type data in cells –
o

o

In Cell D1 type: Totals
In Cell B2 type: 1st Qtr


Drag fill handle to B5



This creates 2nd, 3rd & 4th Qtr

Link to another cell
-

Link cell B6 to D1
o

In Cell B6, press equal ( = )

o

press Enter

o

See B6 change

o
-

click on Cell D1

Change D1: Grand Total

Link to another sheet
-

Link cell C2 to total on 1st Qtr sheet
o

In Cell C2, press equal ( = )

o

Click in D8

o

Click on 1st Qtr sheet

o

Press Enter

-

View Link in formula bar

-

Link Cells C3 to 2nd QTR, C4 to 3rd QTR, C5
to 4th QTR

-

Calculate Grand Total in C6 using the AutoSum

-

Right Align Column B

Test Links
-

Turn to 2nd Qtr sheet
o

In Cell C5 type: 951

o

In Cell C7 type: 357

o

-

In Cell C6 type: 624

View Totals sheet
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Summarize Across Worksheets
-

Create the following Table Starting in cell B10

-

In cell C11 type: =Sum(

-

Click into sheet 1st Qtr and link to cell D5 and press Enter

-

o

C11: =SUM('1st Qtr'!D5)

o

C11: =SUM('1st Qtr:4th Qtr'!D5)

Modify the equation to include the rest of the worksheets
o

Fill the equation down

NOTE: We can only do this because all the worksheets have the value for item A's total in the same cell,
and there are no worksheets between the quarters. If you have other sheets, or there is an inconsistency
in your dataset, you can do this manually by using: ='1st Qtr'!D5+'2nd Qtr'!D5+'3rd Qtr'!D5+'4th Qtr'!D5
-

In cell D11 type: =AVERAGE(

-

Click into sheet 1st Qtr and link to cell D5 and press Enter

-

o

C11: =AVERAGE('1st Qtr'!D5)

o

C11: =AVERAGE('1st Qtr:4th Qtr'!D5)

o

These numbers will be low because of the zeros on 3rd and 4th Qtr

Modify the equation to include the rest of the worksheets
o

Fill the equation down
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Move Totals Sheet to another book
-

Right-click on the worksheet title Totals

-

Choose Move or Copy Sheet…

-

From Book menu choose (new book)

-

View Links in the Totals sheet
o
o

Edit a formula to see one link
Show Formulas to see all (Ctrl-~)


Press Ctrl-~ or Show Formulas from
the Formula tab.

Save Files
-

Save file with the quarter sheets as Quarters (on the desktop)

-

Save file with the total sheet as Totals (on the desktop)

-

View Links in Totals
o

Keyboard Shortcut:
F12 = Save As

='[Quarters.xlsx]1st Qtr'!D8

Viewing multiple files
-

Switching Windows
o

Click on file names in the Windows Taskbar (bottom of window)

o

Press Ctrl-Tab

o

From the View tab, use Switch Windows

-

From the View tab, choose Arrange All

-

Maximize the workbook Quarters

Test Links
-

In the workbook Quarters, turn to 3rd Qtr sheet
o

In Cell C5 type: 967

o

In Cell C7 type: 384

o

-

In Cell C6 type: 688

View the workbook Totals for result
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Close files
-

Close and Save Quarters

-

View Links in Totals (your path will be different for your computer)
o

-

o

='C:\Users\prcowart\Desktop\[Quarters.xlsx]1st Qtr'!D8
Drive, folder, folder,…, file, sheet, cell

Save and Exit Microsoft Excel

Modify Quarters file
-

From the Desktop, Open Quarters (only, don't open Totals)

-

In Quarters file turn to 4th Qtr sheet
o

In Cell C5 type: 900

o

In Cell C7 type: 300

o

-

In Cell C6 type: 600

Close and Save

View Totals file
-

Open Totals File

-

See Security Warning

-

Choose Enable Content (or "Update")

Set up File View
-

Open Quarters File
o

If needed, move to 4th Qtr sheet

o

Tile the windows

From the View Tab, choose Arrange All
In Totals Delete the link for 4th Qtr Total (Cell C5)
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Link Between books
-

Recreate the link
o

o

o

o

Press Equals (=)
Click in the Quarters window
Click in the Quarterly Total cell (D8)
Press Enter

Pasting Link
-

Delete link again from the Totals workbook, cell C5

-

Recreate again using paste link
o

Leave Cell C5 in Totals empty

o

Copy the cell

o

Right-click in Cell C5

o

-

Click on cell D8 in Quarters (4th Qtr)

o

Click in Cell C5 in Totals

o

Choose Paste Link

Exit and save Totals and Quarters

Rename Quarters file
-

On the desktop right-click on the Quarters file

-

Choose Rename, Name the file "FY 19-20"

Modify FY 19-20 file
-

Open FY 19-20

-

If needed, turn to 4th Qtr sheet
o

In Cell C5 type: 975

o

In Cell C7 type: 359

o

-

In Cell C6 type: 684

Save and Exit
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View Totals file with old data
-

Open Totals File

-

Choose Enable Content

-

Click Continue to open the file with "Old" data

-

Exit Microsoft Excel

View Totals file edit links
-

Open Totals File

-

Choose Enable Content

-

Click Edit Links… to find the original file

-

Click Change Source button
o

Find FY19-20 file and click Open

-

View new data

-

Exit Microsoft Excel

Color Worksheet Names
-

Open the Totals file

-

Right-click on the name of each worksheet and change the Tab Color.

View Multiple Sheets of same Book
-

Open FY19-20 File

-

Select All Sheets

-

Change zoom to 100%

-

Drop Group of sheets and
turn to 1st Qtr sheet

-

From the View tab, choose
New Window

-

Arrange All, Tiled

-

Type in one side of the
window to see it happening
live in the other window

-

Choose New Window two
more times

-

Arrange All, Tiled

-

Change each sheet to a
different Qtr so you can see
all four quarters at once

-

Close three windows

-

Maximize the last one
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Printing Multiple Sheets
- Open Print Preview (Ctrl-P or File->Print)
- From the Print Preview menu, change the Setting Print Active Sheets, to Print Entire Workbook
- You should have four pages
-

Go back to Print Active Sheets
Select Sheets 1st Qtr and 3rd Qtr
Print Preview should have 2 pages

-

Select all the sheets
Turn to the Page Layout Tab
o Orientation: Landscape
o Scale: 200%
o Gridlines: Print

-

Print Preview should have 4 pages
Close Print Preview
Ungroup sheets

Helpful Worksheet Tips
Moving
• Ctrl-Page up and Ctrl Page Down move between the worksheets.
• Ctrl-Tab moves between the workbooks.
• The scroll arrows for the sheets move one sheet at a time. Hold down the Ctrl key when you
click to move to the beginning or end of all the sheets.
• Right-click on the scroll arrows to see a list of all the sheets, chose the one you want to
"activate" and click OK.
Multiple sheets
• To see two worksheets from the same book at the same time, choose "New Window" from the
View tab. Arrange the windows.
• Right-click on a worksheet name to SELECT ALL SHEETS and to UNGROUP SHEETS.
• Shift-Click to select a range of sheets.
• Ctrl-Click to select a group of individual sheets.
Printing
• You can print the worksheet name by building a custom header and footer in the Page Setup.
• The Print Preview menu has an option to Print Active Sheets and Print Entire Workbook.
• You can make a selection of sheets with your Shift and Ctrl keys, and then print them at the
same time with the Print Active Sheets.
Cautions
• When you are working with multiple sheets, watch for the word GROUP in the title bar.
• If other files are linked to the one you are working with, be careful in rearranging and renaming
the contents. If you keep both files open, Excel will follow your movements.
• You can always separate the linked files by breaking all the link, see Page 7.
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